aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorvg <vg@devys.org>2018-09-14 11:39:30 +0200
committervg <vg@devys.org>2018-09-14 11:39:30 +0200
commit9e43678b05249510fbfb3b6b7183d0aa60c58681 (patch)
tree36638917c08c5a5cf8fdb8c786a33c78c43dc3de /debian/rules
parent6ea9967850b0c82beec1b56d231b41f5424d8a32 (diff)
downloaddebian-dhcpcd-9e43678b05249510fbfb3b6b7183d0aa60c58681.tar.gz
debian-dhcpcd-9e43678b05249510fbfb3b6b7183d0aa60c58681.tar.bz2
debian-dhcpcd-9e43678b05249510fbfb3b6b7183d0aa60c58681.zip
add overrides for conffilesHEADmaster
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 14 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 9207c67..68ffc5d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,15 +9,27 @@
VERSION = 1
PACKAGEVERSION = $(VERSION)+$(shell date +%Y%m%d%H%M%S)
+LIBEXEC=$(shell echo usr/lib/$(shell dpkg-architecture -q DEB_HOST_MULTIARCH 2>/dev/null) | sed 's,/$$,,')
+HOOKPATH=debian/dhcpcd/$(LIBEXEC)/dhcpcd-hooks
+
export prefix=/usr
export DBDIR=/var/lib/dhcpcd
+%:
+ dh $@ -D upstream
+
override_dh_gencontrol:
dh_gencontrol -- -v$(PACKAGEVERSION)
-%:
- dh $@ -D upstream
+# do not use "install" file since 50-ntp.conf needs a variable and dhcpcd.conf
+# has to be overriden and the "install" file is used *before* the
+# dh_auto_install rule.
+override_dh_install:
+ dh_install
+ install -o root -g root -m 0644 debian/install_files/50-ntp.conf $(HOOKPATH)/
+# install -o root -g root -m 0644 debian/install_files/dhcpcd.conf \
+# debian/dhcpcd/etc/
override_dh_installsystemd:
dh_installsystemd --no-start --no-enable