aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules16
1 files changed, 14 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 9207c67..68ffc5d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,15 +9,27 @@
VERSION = 1
PACKAGEVERSION = $(VERSION)+$(shell date +%Y%m%d%H%M%S)
+LIBEXEC=$(shell echo usr/lib/$(shell dpkg-architecture -q DEB_HOST_MULTIARCH 2>/dev/null) | sed 's,/$$,,')
+HOOKPATH=debian/dhcpcd/$(LIBEXEC)/dhcpcd-hooks
+
export prefix=/usr
export DBDIR=/var/lib/dhcpcd
+%:
+ dh $@ -D upstream
+
override_dh_gencontrol:
dh_gencontrol -- -v$(PACKAGEVERSION)
-%:
- dh $@ -D upstream
+# do not use "install" file since 50-ntp.conf needs a variable and dhcpcd.conf
+# has to be overriden and the "install" file is used *before* the
+# dh_auto_install rule.
+override_dh_install:
+ dh_install
+ install -o root -g root -m 0644 debian/install_files/50-ntp.conf $(HOOKPATH)/
+# install -o root -g root -m 0644 debian/install_files/dhcpcd.conf \
+# debian/dhcpcd/etc/
override_dh_installsystemd:
dh_installsystemd --no-start --no-enable