aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvg <vg@devys.org>2018-09-14 11:39:30 +0200
committervg <vg@devys.org>2018-09-14 11:39:30 +0200
commit9e43678b05249510fbfb3b6b7183d0aa60c58681 (patch)
tree36638917c08c5a5cf8fdb8c786a33c78c43dc3de
parent6ea9967850b0c82beec1b56d231b41f5424d8a32 (diff)
downloaddebian-dhcpcd-9e43678b05249510fbfb3b6b7183d0aa60c58681.tar.gz
debian-dhcpcd-9e43678b05249510fbfb3b6b7183d0aa60c58681.tar.bz2
debian-dhcpcd-9e43678b05249510fbfb3b6b7183d0aa60c58681.zip
add overrides for conffilesHEADmaster
-rw-r--r--debian/install1
-rw-r--r--debian/install_files/50-ntp.conf14
-rw-r--r--debian/install_files/dhcpcd.conf42
-rwxr-xr-xdebian/rules16
m---------upstream0
5 files changed, 71 insertions, 2 deletions
diff --git a/debian/install b/debian/install
new file mode 100644
index 0000000..260c6d0
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+debian/install_files/dhcpcd.conf etc
diff --git a/debian/install_files/50-ntp.conf b/debian/install_files/50-ntp.conf
new file mode 100644
index 0000000..1544ad7
--- /dev/null
+++ b/debian/install_files/50-ntp.conf
@@ -0,0 +1,14 @@
+# Use the more adapted debian script defined by the ntp package directly if it
+# is available.
+
+if [ -f /etc/dhcp/dhclient-exit-hooks.d/ntp ]; then
+ . /etc/dhcp/dhclient-exit-hooks.d/ntp
+fi
+
+# timesyncd is supported too
+if [ -f /etc/dhcp/dhclient-exit-hooks.d/timesyncd ]; then
+ . /etc/dhcp/dhclient-exit-hooks.d/timesyncd
+fi
+
+# there is no script for openntpd readily available
+# there is no script for chrony readily available
diff --git a/debian/install_files/dhcpcd.conf b/debian/install_files/dhcpcd.conf
new file mode 100644
index 0000000..f17ee64
--- /dev/null
+++ b/debian/install_files/dhcpcd.conf
@@ -0,0 +1,42 @@
+# A sample configuration for dhcpcd.
+# See dhcpcd.conf(5) for details.
+
+# Allow users of this group to interact with dhcpcd via the control socket.
+#controlgroup wheel
+
+# Inform the DHCP server of our hostname for DDNS.
+hostname
+
+# Use the hardware address of the interface for the Client ID.
+#clientid
+# or
+# Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
+# Some non-RFC compliant DHCP servers do not reply with this set.
+# In this case, comment out duid and enable clientid above.
+duid
+
+# Persist interface configuration when dhcpcd exits.
+persistent
+
+# Rapid commit support.
+# Safe to enable by default because it requires the equivalent option set
+# on the server to actually work.
+option rapid_commit
+
+# A list of options to request from the DHCP server.
+#option domain_name_servers, domain_name, domain_search, host_name
+option domain_name_servers, domain_name, domain_search
+option classless_static_routes
+# Respect the network MTU. This is applied to DHCP routes.
+option interface_mtu
+
+# Most distributions have NTP support.
+option ntp_servers
+
+# A ServerID is required by RFC2131.
+require dhcp_server_identifier
+
+# Generate SLAAC address using the Hardware Address of the interface
+#slaac hwaddr
+# OR generate Stable Private IPv6 Addresses based from the DUID
+slaac private
diff --git a/debian/rules b/debian/rules
index 9207c67..68ffc5d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -9,15 +9,27 @@
VERSION = 1
PACKAGEVERSION = $(VERSION)+$(shell date +%Y%m%d%H%M%S)
+LIBEXEC=$(shell echo usr/lib/$(shell dpkg-architecture -q DEB_HOST_MULTIARCH 2>/dev/null) | sed 's,/$$,,')
+HOOKPATH=debian/dhcpcd/$(LIBEXEC)/dhcpcd-hooks
+
export prefix=/usr
export DBDIR=/var/lib/dhcpcd
+%:
+ dh $@ -D upstream
+
override_dh_gencontrol:
dh_gencontrol -- -v$(PACKAGEVERSION)
-%:
- dh $@ -D upstream
+# do not use "install" file since 50-ntp.conf needs a variable and dhcpcd.conf
+# has to be overriden and the "install" file is used *before* the
+# dh_auto_install rule.
+override_dh_install:
+ dh_install
+ install -o root -g root -m 0644 debian/install_files/50-ntp.conf $(HOOKPATH)/
+# install -o root -g root -m 0644 debian/install_files/dhcpcd.conf \
+# debian/dhcpcd/etc/
override_dh_installsystemd:
dh_installsystemd --no-start --no-enable
diff --git a/upstream b/upstream
-Subproject 04196311ca704dbe9e60a82ed03090145bd9db5
+Subproject e496358e0c17ebebe7910c5a5927781fb0c24b9