aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorvg <vg@devys.org>2018-07-24 16:10:13 +0200
committervg <vg@devys.org>2018-07-24 16:10:13 +0200
commit0b57ffbcd6d9c49fe90d7e7dc241d034ace943fa (patch)
tree940f8d183f1e89d959d157abe205ba76efb093ba /debian
downloaddebian-dhcpcd-0b57ffbcd6d9c49fe90d7e7dc241d034ace943fa.tar.gz
debian-dhcpcd-0b57ffbcd6d9c49fe90d7e7dc241d034ace943fa.tar.bz2
debian-dhcpcd-0b57ffbcd6d9c49fe90d7e7dc241d034ace943fa.zip
Initial packaging of dhcpcd
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control11
-rw-r--r--debian/dhcpcd.service7
-rwxr-xr-xdebian/rules44
5 files changed, 68 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5565b72
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+dhcpcd (0.0.0) UNRELEASED; urgency=medium
+
+ * Personal package, not meant for official inclusion
+
+ -- vg <vg@devys.org> Sun, 01 Jan 1984 00:00:00 +0000
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..f599e28
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..fd7bdd9
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,11 @@
+Source: dhcpcd
+Section: universe/x11
+Priority: optional
+Maintainer: vg <vg@devys.org>
+Build-Depends: debhelper (>=10), pkg-config, libudev-dev, ntp
+Homepage: https://roy.marples.name/projects/dhcpcd
+
+Package: dhcpcd
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}, bsdutils, procps
+Description: DHCP client for automatically configuring IPv4/IPv6 networking
diff --git a/debian/dhcpcd.service b/debian/dhcpcd.service
new file mode 100644
index 0000000..b016f36
--- /dev/null
+++ b/debian/dhcpcd.service
@@ -0,0 +1,7 @@
+[Service]
+ExecStart=/usr/sbin/dhcpcd -MBq
+Restart=on-abnormal
+KillMode=process
+
+[Install]
+WantedBy=multi-user.target
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9207c67
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,44 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# debian version rule:
+# 0.0 < 0.5 < 0.10 < 0.99 < 1 < 1.0~rc1 < 1.0 < 1.0+b1 < 1.0+nmu1 < 1.1 < 2.0
+
+VERSION = 1
+PACKAGEVERSION = $(VERSION)+$(shell date +%Y%m%d%H%M%S)
+
+export prefix=/usr
+export DBDIR=/var/lib/dhcpcd
+
+override_dh_gencontrol:
+ dh_gencontrol -- -v$(PACKAGEVERSION)
+
+%:
+ dh $@ -D upstream
+
+override_dh_installsystemd:
+ dh_installsystemd --no-start --no-enable
+
+## avoid errors on stretch and sid builds. Kind of Error:
+## dpkg-shlibdeps: error: no dependency information found for
+## /usr/lib/ld-linux-armhf.so.3 (used >by debian/meh/bin/meh)
+## fix by telling dh_shlibdeps it should ignore not found libs:
+#override_dh_shlibdeps:
+# dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
+#
+## note for build:
+## Delete manpages installed from upstream since not gzipped, and let debian
+## helper do it instead.
+#override_dh_auto_clean:
+#override_dh_auto_test:
+#override_dh_auto_build:
+#override_dh_auto_install:
+# (cd upstream && dh_auto_configure)
+# make -C upstream
+# make -C upstream install DESTDIR="$(PWD)/debian/dhcpcd"
+# echo "debug: `pwd`"
+# echo $(PWD)
+# find debian/dhcpcd