aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules44
1 files changed, 44 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9207c67
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,44 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# debian version rule:
+# 0.0 < 0.5 < 0.10 < 0.99 < 1 < 1.0~rc1 < 1.0 < 1.0+b1 < 1.0+nmu1 < 1.1 < 2.0
+
+VERSION = 1
+PACKAGEVERSION = $(VERSION)+$(shell date +%Y%m%d%H%M%S)
+
+export prefix=/usr
+export DBDIR=/var/lib/dhcpcd
+
+override_dh_gencontrol:
+ dh_gencontrol -- -v$(PACKAGEVERSION)
+
+%:
+ dh $@ -D upstream
+
+override_dh_installsystemd:
+ dh_installsystemd --no-start --no-enable
+
+## avoid errors on stretch and sid builds. Kind of Error:
+## dpkg-shlibdeps: error: no dependency information found for
+## /usr/lib/ld-linux-armhf.so.3 (used >by debian/meh/bin/meh)
+## fix by telling dh_shlibdeps it should ignore not found libs:
+#override_dh_shlibdeps:
+# dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
+#
+## note for build:
+## Delete manpages installed from upstream since not gzipped, and let debian
+## helper do it instead.
+#override_dh_auto_clean:
+#override_dh_auto_test:
+#override_dh_auto_build:
+#override_dh_auto_install:
+# (cd upstream && dh_auto_configure)
+# make -C upstream
+# make -C upstream install DESTDIR="$(PWD)/debian/dhcpcd"
+# echo "debug: `pwd`"
+# echo $(PWD)
+# find debian/dhcpcd