aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVG <vg@devys.org>2016-11-03 16:46:46 +0100
committerVG <vg@devys.org>2016-11-03 16:46:46 +0100
commit2b31572424504f5a39ddd24e9264e174ea28096d (patch)
tree0714d8b05a37b09091a0eeb99b88607dfb0c7609
downloaddebian-ponymix-2b31572424504f5a39ddd24e9264e174ea28096d.tar.gz
debian-ponymix-2b31572424504f5a39ddd24e9264e174ea28096d.tar.bz2
debian-ponymix-2b31572424504f5a39ddd24e9264e174ea28096d.zip
first commit (currently just a copy of meh)
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control16
-rw-r--r--debian/meh.manpages1
-rwxr-xr-xdebian/rules37
5 files changed, 60 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..1c63dab
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+meh (0-0) UNRELEASED; urgency=medium
+
+ * Personal package, not meant for official inclusion
+
+ -- vg <vg@devys.org> Sun, 01 Jan 1984 00:00:00 +0000
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..f599e28
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+10
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..3127f40
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,16 @@
+Source: meh
+Section: universe/x11
+Priority: optional
+Maintainer: vg <vg@devys.org>
+Build-Depends: debhelper (>=9),
+ libxext-dev, libpng-dev, libgif-dev, libjpeg-dev, zlib1g-dev
+Homepage: https://github.com/jhawthorn/meh/
+#Vcs-Git: git://git.debian.org/collab-maint/meh.git
+#Vcs-Browser: http://git.debian.org/?p=collab-maint/meh.git;a=summary
+
+Package: meh
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: Lightweight image viewer for X11
+ Fast, lightweight image viewer. In its control mode, it can read next image
+ to be displayed from stdin. Uses xlib.
diff --git a/debian/meh.manpages b/debian/meh.manpages
new file mode 100644
index 0000000..851fa79
--- /dev/null
+++ b/debian/meh.manpages
@@ -0,0 +1 @@
+upstream/doc/meh.1
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..a479493
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,37 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# debian version rule:
+# 0.0 < 0.5 < 0.10 < 0.99 < 1 < 1.0~rc1 < 1.0 < 1.0+b1 < 1.0+nmu1 < 1.1 < 2.0
+
+VERSION = 0.3
+PACKAGEVERSION = $(VERSION)+$(shell date +%Y%m%d%H%M%S)
+
+%:
+ dh $@
+
+# avoid errors on stretch and sid builds. Error :
+# dpkg-shlibdeps: error: no dependency information found for
+# /usr/lib/ld-linux-armhf.so.3 (used >by debian/meh/bin/meh)
+# fix by telling dh_shlibdeps it should ignore not found libs:
+override_dh_shlibdeps:
+ dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
+
+# note for build:
+# Delete manpages installed from upstream since not gzipped, and let debian
+# helper do it instead.
+override_dh_auto_clean:
+override_dh_auto_test:
+override_dh_auto_build:
+override_dh_auto_install:
+ make -C upstream
+ make -C upstream install PREFIX=../debian/meh/usr
+ rm -f ../debian/meh/usr/share/man/man1/meh.1
+ dh_installman
+
+
+override_dh_gencontrol:
+ dh_gencontrol -- -v$(PACKAGEVERSION)