aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorVG <vg@devys.org>2016-09-11 19:03:48 +0200
committerVG <vg@devys.org>2016-09-11 19:03:48 +0200
commit0c1d7d24c316d3a7c8e766483da9b5e0e8765b09 (patch)
tree31563e653f6037c532fecd092ee0d8d7582c32b1 /debian/rules
parent8f23c81c8d9c85ab4513acbdbaa1cbaef6418911 (diff)
downloaddebian-meh-0c1d7d24c316d3a7c8e766483da9b5e0e8765b09.tar.gz
debian-meh-0c1d7d24c316d3a7c8e766483da9b5e0e8765b09.tar.bz2
debian-meh-0c1d7d24c316d3a7c8e766483da9b5e0e8765b09.zip
new package autobuild method
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules19
1 files changed, 15 insertions, 4 deletions
diff --git a/debian/rules b/debian/rules
index 6222c9b..fcc17c2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,17 +4,28 @@
# Uncomment this to turn on verbose mode.
#export DH_VERBOSE=1
-export PREFIX:=/usr
+# debian version rule:
+# 0.0 < 0.5 < 0.10 < 0.99 < 1 < 1.0~rc1 < 1.0 < 1.0+b1 < 1.0+nmu1 < 1.1 < 2.0
+
+VERSION = 0.3
+PACKAGEVERSION = $(VERSION)+$(shell date +%Y%m%d%H%M%S)
%:
dh $@
+# note for build:
# Delete manpages installed from upstream since not gzipped, and let debian
# helper do it instead.
-override_dh_installman:
+override_dh_auto_clean:
+override_dh_auto_test:
+override_dh_auto_build:
+override_dh_auto_install:
+ git clone --depth 1 /home/calendros/seele/autobuild/upstream/meh src
+ make -C src
+ make -C src install PREFIX=debian/meh
rm debian/meh/usr/share/man/man1/meh.1
dh_installman
-override_dh_auto_test:
- echo "bypass test because it fails on amd64 build"
+override_dh_gencontrol:
+ dh_gencontrol -- -v$(PACKAGEVERSION)