aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py36
1 files changed, 36 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..a75b0f8
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,36 @@
+#!/usr/bin/env python
+
+import os
+import sys
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+if sys.argv[-1] == 'publish':
+ os.system('python setup.py sdist upload')
+ sys.exit()
+
+setup(
+ name="anidb",
+ version="0.0.1",
+ description="AniDB API wrapper",
+ long_description="",
+ url="https://github.com/iamale/anidb.py",
+ author="Ale",
+ author_email="ale@incrowd.ws",
+ packages=['anidb'],
+ package_dir={'anidb': 'anidb'},
+ install_requires=["requests==2.3.0", "beautifulsoup4==4.3.2"],
+ license='MIT',
+ classifiers=(
+ 'Development Status :: 2 - Pre-Alpha',
+ 'Intended Audience :: Developers',
+ 'Natural Language :: English',
+ 'License :: OSI Approved :: MIT License',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7'
+ ),
+)