aboutsummaryrefslogtreecommitdiffstats
path: root/trio/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'trio/Makefile.in')
-rw-r--r--trio/Makefile.in9
1 files changed, 5 insertions, 4 deletions
diff --git a/trio/Makefile.in b/trio/Makefile.in
index 7be4bcb1..f57f16ba 100644
--- a/trio/Makefile.in
+++ b/trio/Makefile.in
@@ -1,5 +1,6 @@
+SHELL = @SHELL@
CC = @CC@
-CFLAGS = @CFLAGS@ -DDEBUG
+CFLAGS = @CFLAGS@ -I. -DDEBUG
OBJS = triostr.o trio.o trionan.o
TARGETLIB = libtrio.a
TARGETINCS = trio.h triop.h triodef.h trionan.h triostr.h
@@ -23,14 +24,14 @@ libdir = @libdir@
all: $(TARGETLIB) $(TARGET) regression
-test:
+test: all
./regression
install: $(TARGETLIB)
$(MKDIR) $(libdir)
$(MKDIR) $(includedir)
$(INSTALL_DATA) $(TARGETLIB) $(libdir)/$(TARGETLIB)
- for i in $(TARGET_INCS);do \
+ for i in $(TARGETINCS);do \
(set -x;$(INSTALL_DATA) $$i $(includedir)); \
done
@@ -57,4 +58,4 @@ doc::
$(GENDOC) doc/trio.cfg
clean:
- $(ERASE) *~ core regression example $(TOBJS) $(OBJS) $(TARGET) $(TARGETLIB) example.o regression.o
+ $(ERASE) *~ core core.* regression example $(TOBJS) $(OBJS) $(TARGET) $(TARGETLIB) example.o regression.o