aboutsummaryrefslogtreecommitdiffstats
path: root/trio/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'trio/Makefile.in')
-rw-r--r--trio/Makefile.in32
1 files changed, 22 insertions, 10 deletions
diff --git a/trio/Makefile.in b/trio/Makefile.in
index f57f16ba..4f3b9692 100644
--- a/trio/Makefile.in
+++ b/trio/Makefile.in
@@ -10,9 +10,11 @@ RANLIB = @RANLIB@
ERASE = rm -f
MKDIR = mkdir -p
GENDOC = doxygen
-
-PURIFY = purify
-PURIFYOPTIONS = -chain-length=16 -first-only=YES
+srcdir = @srcdir@
+# VPATH doesn't seem to work with /usr/xpg4/bin/make on Solaris
+# (use /usr/ccs/bin/make), and doesn't work on older Solaris make
+# such as Solaris 2.6.
+VPATH = @srcdir@
# Installation settings
INSTALL = @INSTALL@
@@ -22,9 +24,22 @@ exec_prefix = @exec_prefix@
includedir = @includedir@
libdir = @libdir@
-all: $(TARGETLIB) $(TARGET) regression
+all: $(TARGETLIB) $(TARGET)
+
+.PHONY: all check test install doc clean
+
+$(srcdir)/configure: configure.in
+ cd $(srcdir) && autoconf
-test: all
+Makefile: Makefile.in config.status
+ CONFIG_COMMANDS= CONFIG_LINKS= CONFIG_HEADERS= \
+ CONFIG_FILES=Makefile ./config.status
+
+config.status: configure
+ ./config.status --recheck
+
+check: test
+test: regression
./regression
install: $(TARGETLIB)
@@ -32,12 +47,9 @@ install: $(TARGETLIB)
$(MKDIR) $(includedir)
$(INSTALL_DATA) $(TARGETLIB) $(libdir)/$(TARGETLIB)
for i in $(TARGETINCS);do \
- (set -x;$(INSTALL_DATA) $$i $(includedir)); \
+ (set -x;$(INSTALL_DATA) $(srcdir)/$$i $(includedir)); \
done
-pure: $(TOBJS) $(OBJS)
- $(PURIFY) $(PURIFYOPTIONS) $(CC) $(CFLAGS) $^ $(LDFLAGS)
-
regression: regression.o $(TARGETLIB)
$(CC) $(CFLAGS) regression.o $(LDFLAGS) -o $@
@@ -55,7 +67,7 @@ $(TARGETLIB): $(OBJS)
$(RANLIB) $(TARGETLIB)
doc::
- $(GENDOC) doc/trio.cfg
+ (cd $(srcdir) && $(GENDOC) doc/trio.cfg)
clean:
$(ERASE) *~ core core.* regression example $(TOBJS) $(OBJS) $(TARGET) $(TARGETLIB) example.o regression.o