aboutsummaryrefslogtreecommitdiffstats
path: root/specgen.sh
diff options
context:
space:
mode:
Diffstat (limited to 'specgen.sh')
-rwxr-xr-xspecgen.sh18
1 files changed, 13 insertions, 5 deletions
diff --git a/specgen.sh b/specgen.sh
index 7531aa27..5134e6df 100755
--- a/specgen.sh
+++ b/specgen.sh
@@ -1,11 +1,19 @@
+#!/bin/sh
+
+user=`whoami`
+name=`grep "^${user}:" /etc/passwd | cut -d: -f5|sed -e 's/^.*,//'`
+domain=mail.berlios.de
+email="$user@$domain"
+packager="$name <$email>"
+
cat <<EOF
# Note: Do not hack fetchmail.spec by hand -- it's generated by specgen.sh
Name: fetchmail
Version: $1
Release: 1
-Vendor: Eric Conspiracy Secret Labs
-Packager: Eric S. Raymond <esr@thyrsus.com>
-URL: http://www.catb.org/~esr/fetchmail/
+Vendor: The Community Fetchmail Project
+Packager: $packager
+URL: http://developer.berlios.de/projects/fetchmail
Source: %{name}-%{version}.tar.gz
Group: Applications/Mail
Group(pt_BR): Aplicações/Correio Eletrônico
@@ -23,7 +31,7 @@ Summary(tr): POP2, POP3, APOP, IMAP protokolleri ile uzaktan mektup alma yazý
Summary(da): Alsidig POP/IMAP post-afhentnings dæmon
BuildRoot: %{_tmppath}/%{name}-root
#Keywords: mail, client, POP, POP2, POP3, APOP, RPOP, KPOP, IMAP, ETRN, ODMR, SMTP, ESMTP, GSSAPI, RPA, NTLM, CRAM-MD5, SASL
-#Destinations: fetchmail-friends@ccil.org, fetchmail-announce@ccil.org
+#Destinations: fetchmail-users@lists.berlios.de, fetchmail-announce@lists.berlios.de
%description
Fetchmail is a free, full-featured, robust, and well-documented remote
@@ -155,6 +163,6 @@ rm -rf \$RPM_BUILD_ROOT
/usr/lib/rhs/control-panel/fetchmailconf.init
%changelog
-* `date '+%a %b %d %Y'` <esr@thyrsus.com> ${version}
+* `date '+%a %b %d %Y'` <$email> ${version}
- See the project news file for recent changes.
EOF