aboutsummaryrefslogtreecommitdiffstats
path: root/dist-tools/getstats.py
diff options
context:
space:
mode:
Diffstat (limited to 'dist-tools/getstats.py')
-rwxr-xr-xdist-tools/getstats.py20
1 files changed, 6 insertions, 14 deletions
diff --git a/dist-tools/getstats.py b/dist-tools/getstats.py
index df2fbeaf..f48c153a 100755
--- a/dist-tools/getstats.py
+++ b/dist-tools/getstats.py
@@ -4,28 +4,20 @@
import commands, os, string, ftplib
-print "This script must be adjusted for Git."
-exit(1)
-
# Get version and date
-date = commands.getoutput("LC_TIME=C date -u")
+date = commands.getoutput("LC_TIME=C date +'%Y-%m-%d'")
pid = os.getpid()
-if True:
- # this is a fast variant using the base of the current working directory
- # (ignores uncommitted modifications)
- cmd = "svn export -q -rBASE . /tmp/getstats.%d" % pid
-else:
- # this is a slower variant that may export the whole tree across
- # the net
- cmd = "svn export -rCOMMITTED . /tmp/getstats.%d" % pid
+os.mkdir("/tmp/getstats.%d" % pid)
+
+cmd = "git archive --format=tar HEAD | ( cd /tmp/getstats.%d && tar -xf -)" % pid
if os.system(cmd):
- print "SVN FAILED"
+ print "git-archive FAILED"
os.exit(1)
ln = commands.getoutput("cat /tmp/getstats.%d/*.[chly] 2>/dev/null | wc -l" % pid)
os.system("rm -rf /tmp/getstats.%d" % pid)
vers = commands.getoutput("sed -n -e '/AC_INIT/s/AC_INIT(\\[.\\+\\],\\[\\(.*\\)\\],.*)/\\1/p' <configure.ac")
-print "fetchmail-" + vers + " (" + date + "), " + string.strip(ln) + " lines:"
+print "fetchmail-" + vers + " (released " + date + ", " + string.strip(ln) + " LoC):"
# end of getstats.py