aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 29 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c9a10f1b..677ef6f3 100644
--- a/configure.in
+++ b/configure.in
@@ -196,6 +196,35 @@ then
AC_DEFINE(OPIE,1)
fi
+### use option --with-gssapi=DIR to compile in GSSAPI support
+AC_ARG_WITH(gssapi,
+ [ --with-gssapi[=DIR] compile in GSSAPI support using libraries in DIR])
+if test "$with-gssapi" = "yes"
+then
+ GSSAPIDIR="/usr /usr/local /usr/athena"
+else
+ GSSAPIDIR="$with_gssapi"
+fi
+if test "$GSSAPIDIR" != "" -a "$GSSAPIDIR" != "no"
+then
+ AC_MSG_CHECKING([for gssapi])
+ for curgssapidir in $GSSAPIDIR
+ do
+ if test -f $curgssapidir/include/gssapi/gssapi.h
+ then
+ CEFLAGS="$CEFLAGS -DGSSAPI -I$curgssapidir/include"
+ LDEFLAGS="$LDEFLAGS -L$curgssapidir/lib"
+ LIBS="$LIBS -lgssapi_krb5 -lkrb5"
+ AC_MSG_RESULT([in $curgssapidir])
+ GSSAPIFOUND="yes"
+ fi
+ done
+ if test "$GSSAPIFOUND" != "yes"
+ then
+ AC_MSG_ERROR([not found])
+ fi
+fi
+
### use option --with-kerberos=DIR to point at a Kerberos directory
AC_ARG_WITH(kerberos,
[ --with-kerberos=DIR point fetchmail compilation at a Kerberos directory])