aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e893585b..710a93fc 100644
--- a/configure.in
+++ b/configure.in
@@ -389,6 +389,15 @@ directory],
[
if test "$with_kerberos5" != "no"
then
+# Check for a OpenBSD special case
+if test "$with_kerberos5" = "yes" && ( test `uname` = "OpenBSD" )
+then
+ AC_CHECKING([kerberosV for OpenBSD])
+ AC_DEFINE(HEIMDAL)
+ AC_DEFINE(KERBEROS_V5)
+ CEFLAGS="$CEFLAGS -I/usr/include/kerberosV"
+ LIBS="$LIBS -lasn1 -lkrb5 -lcom_err"
+else
if test "$with_kerberos5" != "yes"
then
LDEFLAGS="$LDEFLAGS -L${with_kerberos5}/lib"
@@ -446,6 +455,7 @@ then
AC_ERROR([Kerberos 5 libraries not found])
fi
fi
+fi
]) dnl --with-kerberos5=DIR
### use option --with-kerberos=DIR to point at a Kerberos 4 directory