aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 9 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index a32e67ce..3e438586 100644
--- a/configure.in
+++ b/configure.in
@@ -358,8 +358,8 @@ fi
### use option --with-ssl to compile in the SSL support
AC_ARG_WITH(ssl,
- [ --with-ssl[=DIR] enable SSL support using libraries in DIR]
- [with_ssl=$enableval],
+ [ --with-ssl=[DIR] enable SSL support using libraries in DIR],
+ [with_ssl=$withval],
[with_ssl=no])
test "$with_netsec" = "yes" && AC_DEFINE(SSL_ENABLE)
@@ -401,6 +401,11 @@ then
### ssl.h found under openssl. Use openssl configuration preferentially
echo "Enabling OpenSSL support in $with_ssl"
CEFLAGS="$CEFLAGS -I$with_ssl/include -I$with_ssl/include/openssl"
+### OpenBSD comes with ssl headers
+ elif test -r /usr/include/ssl/ssl.h
+ then
+ echo "Enabling SSLeay support in $with_ssl"
+ CEFLAGS="$CEFLAGS -I/usr/include/ssl"
else
echo "Enabling SSLeay support in $with_ssl"
CEFLAGS="$CEFLAGS -I$with_ssl/include"
@@ -526,10 +531,9 @@ then
LDFLAGS="$LDFLAGS -L$with_gssapi/lib"
fi
- AC_CHECK_LIB(krb5, krb5_init_context,,
- AC_MSG_ERROR([could not find libkrb5 which is needed for GSSAPI support]))
- if test -f "$with_kerberos5/include/roken.h"
+ if test -f "$with_gssapi/include/roken.h"
then
+ LIBS="$LIBS -lkrb5 -lasn1 -ldes -lroken -ldb -ldl"
AC_CHECK_LIB(gssapi, gss_init_sec_context,LIBS="$LIBS -lgssapi",
AC_MSG_ERROR([could not find libgssapi which is needed for GSSAPI support]), )
AC_DEFINE(HEIMDAL)
@@ -546,7 +550,6 @@ then
else
AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi/gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE))
fi
- CPPFLAGS=$save_CPPFLAGS
fi])
AC_OUTPUT([Makefile intl/Makefile po/Makefile.in], [