aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 4398fa4c..d98ceff8 100644
--- a/configure.in
+++ b/configure.in
@@ -8,8 +8,8 @@ AC_INIT(fetchmail.h) dnl A distinctive file to look for in srcdir.
AC_CONFIG_HEADER(config.h)
# We want these before the checks, so the checks can modify their values.
-test -z "$CFLAGS" && CFLAGS=-g AC_SUBST(CFLAGS)
-test -z "$LDFLAGS" && LDFLAGS=-g AC_SUBST(LDFLAGS)
+test -z "$CFLAGS" && CFLAGS=-O AC_SUBST(CFLAGS)
+test -z "$LDFLAGS" && LDFLAGS=-s AC_SUBST(LDFLAGS)
AC_CANONICAL_HOST
AC_PROG_CC
@@ -131,6 +131,13 @@ AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
+### use option --enable-POP2 to compile in the POP2 fallback support
+AC_ARG_ENABLE(POP2,
+ [ --enable-POP2 compile in POP2 protocol support (obsolete)],
+ [with_POP2=$enableval],
+ [with_POP2=no])
+test "$with_POP2" = "yes" && AC_DEFINE(POP2_ENABLE)
+
AC_OUTPUT(Makefile, [
# Makefile uses this timestamp file to know when to remake Makefile,
# build.sh, and glob/Makefile.