aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 9 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index d406ab2c..562f4fa9 100644
--- a/configure.in
+++ b/configure.in
@@ -31,9 +31,16 @@ AC_PROG_LEX
AC_PROG_YACC
AC_SUBST(LIBOBJS)
+# Under sysV68, socket and friends are provided by the C library.
+# -linet does not provide socket, but causes multiple definition
+# errors at link-time. It is thus better to only use the C library.
+# So don't add -linet to the link list unless it's necessary
+AC_CHECK_FUNC(socket,
+ AC_MSG_RESULT(using libc's socket),
+ AC_CHECK_LIB(socket,socket)
+ AC_CHECK_LIB(inet,socket))
+
AC_CHECK_LIB(nsl,inet_addr)
-AC_CHECK_LIB(socket,socket)
-AC_CHECK_LIB(inet,socket)
AC_CHECK_LIB(opie,opiegenerator)
dnl Port hack for Interactive UNIX System V/386 Release 3.2