aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index f4cc65f8..54722f86 100644
--- a/configure.in
+++ b/configure.in
@@ -331,10 +331,10 @@ AC_ARG_WITH(kerberos,
# The "elif" arm (nonempty $with_kerberos) is kind of a crock. It works for
# configuring the BSD/OS Kerberos IV support, though.
-# Check for a NetBSD special case
-if test "$with_kerberos" = "yes" -a `uname` = "NetBSD"
+# Check for a NetBSD/OpenBSD special case
+if test "$with_kerberos" = "yes" -a `uname` = "NetBSD" -o `uname` = "OpenBSD"
then
- echo "Configuring kerberosIV for NetBSD"
+ echo "Configuring kerberosIV for `uname`"
CEFLAGS="$CEFLAGS -DKERBEROS_V4 -I/usr/include/kerberosIV"
LIBS="$LIBS -lkrb -ldes"
elif test -n "$with_kerberos" -a -n "$with_kerberos5"