aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index f74123f3..db6e846d 100644
--- a/configure.in
+++ b/configure.in
@@ -157,8 +157,11 @@ else
fi
AC_OUTPUT(Makefile, [
+ # The reason for this odd makedepend line is that we want
+ # to have all dependencies evaluated relative to the source directory
+ # and let VPATH do all the dirty work when we build remotely
echo "You can ignore any makedepend error messages";
- makedepend -I$srcdir -I. -fMakefile ${srcdir}/*.c])
+ (cd $srcdir; makedepend -f - *.c) >>Makefile])
dnl Local Variables:
dnl comment-start: "dnl "