aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e453268f..7b47be0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -448,10 +448,11 @@ else
with_kerberos5=
for dir in $searchdirs
do AC_MSG_CHECKING([for Kerberos V in $dir])
- if test -f "$dir/include/krb5.h"
+ if test -f "$dir/include/krb5.h" || test -f "$dir/include/krb5/krb5.h"
then
+ if test -d "$dir/include/krb5" ; then CPFLAGS="$CPFLAGS -I$dir/include/krb5" ; fi
ac_krblibs=
- if test -f "$dir/include/roken.h"
+ if test -f "$dir/include/roken.h" || test -f "$dir/include/krb5/roken.h"
then
ac_krblibs="-lasn1 -lroken -lcom_err"
AC_MSG_RESULT([Heimdal found])