aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 38551962..4fb2f4e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -350,7 +350,14 @@ AC_ARG_ENABLE(SDPS,
[ --enable-SDPS compile in SDPS protocol support],
[with_SDPS=$enableval],
[with_SDPS=no])
-test "$with_SDPS" = "yes" && AC_DEFINE(SDPS_ENABLE,1,Define if you want SDPS support compiled in)
+if test "$with_SDPS" = yes ; then
+ if test "$with_POP3" != yes ; then
+ AC_MSG_WARN([SDPS cannot be enabled with POP3 disabled. Disabling SDPS.])
+ with_SDPS=no
+ else
+ AC_DEFINE(SDPS_ENABLE,1,Define if you want SDPS support compiled in)
+ fi
+fi
### use option --enable-opie to compile in the OPIE support
AC_ARG_ENABLE(opie,