aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d026a662..fa9505d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -775,7 +775,7 @@ then
PKG_CHECK_MODULES([SSL],[libssl libcrypto],[LIBS="$LIBS $SSL_LIBS"],[
AS_MESSAGE([SSL-check: pkg-config check failed, using traditional probe])
LDFLAGS="$LDFLAGS -L$with_ssl/lib"
- LIBS="$LIBS -lssl -lcrypto"
+ #LIBS="$LIBS -lssl -lcrypto" # replaced by AC_LIB_LINKFLAGS below
dnl check if -ldl is needed
AC_MSG_CHECKING([for additional library dependencies of SSL])
found=0
@@ -799,6 +799,12 @@ else
AC_MSG_WARN(Consider re-running configure --with-ssl.)
fi
+AC_LIB_LINKFLAGS([crypto])
+AC_LIB_LINKFLAGS([ssl], [crypto])
+
+LIBS="$LIBS $LIBSSL $LIBCRYPTO"
+AC_MSG_NOTICE([LIBS:] "$LIBS")
+
case "$LIBS" in *-lssl*)
AC_CHECK_DECLS([TLS1_3_VERSION],,
AC_MSG_WARN([Your OpenSSL version is too old and does not support TLS v1.3. Upgrade.]),