aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 554d152c..203469b1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -801,10 +801,13 @@ else
AC_MSG_WARN(Consider re-running configure --with-ssl.)
fi
-AC_LIB_LINKFLAGS([crypto])
-AC_LIB_LINKFLAGS([ssl], [crypto])
+if test "$cross_compiling" != yes
+then
+ AC_LIB_LINKFLAGS([crypto])
+ AC_LIB_LINKFLAGS([ssl], [crypto])
-LIBS="$LIBS $LIBSSL $LIBCRYPTO"
+ LIBS="$LIBS $LIBSSL $LIBCRYPTO"
+fi
AC_MSG_NOTICE([LIBS:] "$LIBS")
case "$LIBS" in *-lssl*|*libssl*)