aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 7 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f8e4ca84..7cacff99 100644
--- a/configure.ac
+++ b/configure.ac
@@ -889,9 +889,15 @@ AS_MESSAGE([
LIBS: $LIBS])
case "$LIBS" in *-lssl*|*libssl*|*-lwolfssl*|*libwolfssl*)
- AC_CHECK_DECLS([LIBRESSL_VERSION_NUMBER],
+ case $host_os in
+ openbsd*) ;; dnl OpenBSD ships LibreSSL in the base operating system
+ dnl so makes use of the GPL2 clause 3 exception.
+ *)
+ AC_CHECK_DECLS([LIBRESSL_VERSION_NUMBER],
AC_MSG_ERROR([fetchmail cannot legally be linked against LibreSSL for lack of GPL2 clause 2b exception. See COPYING.]),,
[#include <openssl/ssl.h>])
+ ;;
+ esac
AC_CHECK_DECLS([TLS1_3_VERSION],,
AC_MSG_WARN([Your OpenSSL version is too old and does not support TLS v1.3. Upgrade.]),
[#include <openssl/ssl.h>])