aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c6078d57..646f9768 100644
--- a/configure.ac
+++ b/configure.ac
@@ -732,10 +732,16 @@ then
if test -n "$nogss"
then
# -lgss not found
- if test -f "$with_gssapi/include/roken.h"
+ if test "$with_gssapi" = yes ; then
+ with_gssapi=/usr
+ fi
+ if test -f "$with_gssapi/include/roken.h" -o -f "$with_gssapi/include/krb5/roken.h"
then
# have roken.h, assume Heimdal
- LIBS="$LIBS -lkrb5 -lasn1 -ldes -lroken -ldb -ldl"
+ case `uname` in
+ NetBSD) LIBS="$LIBS -lkrb5" ;;
+ *) LIBS="$LIBS -lkrb5 -lasn1 -ldes -lroken -ldb -ldl" ;;
+ esac
AC_CHECK_LIB(gssapi, gss_init_sec_context,LIBS="$LIBS -lgssapi",
AC_MSG_ERROR([could not find libgssapi which is needed for GSSAPI support]), )
AC_DEFINE(HEIMDAL)