aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ff24c2f7..6c55c30c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -838,15 +838,13 @@ else
PKG_CHECK_MODULES([SSL],[$i],[
set -- $SSL_LIBS
while test $# -ge 1 ; do
- case $1 in -l*|lib*) : ;;
+ case $1 in -l*|lib*) LIBS="$LIBS $1" ;;
*) LDFLAGS="$LDFLAGS $1" ;;
esac
shift
done
CPPFLAGS="$SSL_CFLAGS $CPPFLAGS"
- AC_LIB_LINKFLAGS([ssl], [crypto])
- AS_MESSAGE([From pkg-config: Adding $LIBSSL to LIBS. LDFLAGS=$LDFLAGS])
- LIBS="$LIBS $LIBSSL"
+ AS_MESSAGE([From pkg-config: $SSL_LIBS])
found=1
break],[: ignore-error])
done