aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31373d2a..f1a58c3a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -799,6 +799,9 @@ else
fi
case "$LIBS" in *-lssl*)
+ AC_CHECK_DECLS([TLS1_3_VERSION],,
+ AC_MSG_WARN([Your OpenSSL version is too old and does not support TLS v1.3. Upgrade.]),
+ [#include <openssl/ssl.h>])
AC_CHECK_DECLS([TLS1_2_VERSION],,
AC_MSG_ERROR([Your OpenSSL version is too old and does not support TLS v1.2. Upgrade.]),
[#include <openssl/ssl.h>])