aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14d8c8ab..533bb05c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -760,6 +760,11 @@ if test "$with_wolfssl" != "no" ; then
AC_DEFINE(SSL_ENABLE, 1)
AS_MESSAGE(Enabling SSL support through wolfSSL.)
with_ssl=yes
+ if test -z "$WOLFSSL_TRUST_FILE" ; then
+ AC_MSG_ERROR([You must define WOLFSSL_TRUST_FILE and point it to the default CA certificate file (PEM format)])
+ fi
+ AC_DEFINE_UNQUOTED(WOLFSSL_TRUST_FILE, "$WOLFSSL_TRUST_FILE",
+ [Set to the default file of trusted certificates.])
else
### use option --with-ssl to compile in the SSL support