aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cd1cefe2..5799f8eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,7 +30,11 @@ dnl python is optional
#
# recent Python 3.x versions are supported.
#
-AM_PATH_PYTHON(2.7,,AC_MSG_WARN([Disabling fetchmailconf: python 2.7 or greater not found]))
+try27=0
+AM_PATH_PYTHON([3.7],,[try27=1])
+if test try27 != 0 ; then
+ AM_PATH_PYTHON([2.7],,AC_MSG_WARN([[Disabling fetchmailconf: python 2.7 or 3.7 or greater not found]]) )
+fi
AM_CONDITIONAL([HAVE_PYTHON], [test "$PYTHON" != :])
AC_USE_SYSTEM_EXTENSIONS