aboutsummaryrefslogtreecommitdiffstats
path: root/bootstrap.sh
diff options
context:
space:
mode:
Diffstat (limited to 'bootstrap.sh')
-rwxr-xr-xbootstrap.sh19
1 files changed, 19 insertions, 0 deletions
diff --git a/bootstrap.sh b/bootstrap.sh
new file mode 100755
index 00000000..4503c596
--- /dev/null
+++ b/bootstrap.sh
@@ -0,0 +1,19 @@
+#! /bin/sh
+
+# bootstrap.sh - bootstrap the fetchmail build after a fresh subversion checkout
+# (C) 2004 Matthias Andree -- GNU GPL V2
+
+set -e
+# sanity checks:
+test -f fetchmail.h
+test -f fetchmail.c
+test -f Makefile.am
+rm -rf autom4te.cache
+echo
+echo "Please stand by while generating files with autoreconf, this may"
+echo "take a minute or two..."
+echo
+autoreconf -isv
+echo
+echo "You can now run ./configure and make as usual. See INSTALL for details."
+echo