aboutsummaryrefslogtreecommitdiffstats
path: root/bootstrap.sh
diff options
context:
space:
mode:
Diffstat (limited to 'bootstrap.sh')
-rwxr-xr-xbootstrap.sh24
1 files changed, 21 insertions, 3 deletions
diff --git a/bootstrap.sh b/bootstrap.sh
index 4503c596..4202e5ee 100755
--- a/bootstrap.sh
+++ b/bootstrap.sh
@@ -10,10 +10,28 @@ test -f fetchmail.c
test -f Makefile.am
rm -rf autom4te.cache
echo
-echo "Please stand by while generating files with autoreconf, this may"
-echo "take a minute or two..."
+echo "Please stand by while generating files,"
+echo "this may take a minute or two..."
echo
-autoreconf -isv
+# Original autogen.sh:
+#rm -f po/Makefile.in.in po/ChangeLog po/ChangeLog~ || true
+#gettextize -c -f || true
+
+# do not use -s here, Eric S. Raymond (ESR) writes they don't
+# work well in Debian's build system
+autoreconf -iv
+
+# Taken from ESR's autgen.sh:
+#
+# For the Debian build, refresh list of +x scripts, to avoid
+# possible breakage if upstream tarball does not include the file
+# or if it is mispackaged for whatever reason
+#
+test -d debian && {
+ rm -f debian/executable.files
+ find -type f -perm +111 ! -name '.*' -fprint debian/executable.files
+}
+
echo
echo "You can now run ./configure and make as usual. See INSTALL for details."
echo