aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in330
1 files changed, 0 insertions, 330 deletions
diff --git a/Makefile.in b/Makefile.in
deleted file mode 100644
index 580d46f1..00000000
--- a/Makefile.in
+++ /dev/null
@@ -1,330 +0,0 @@
-# Makefile for fetchmail
-
-# If you're running QNX, we can't assume a working autoconf.
-# So just uncomment all the lines marked QNX.
-
-PACKAGE = fetchmail
-VERSION = 6.2.6
-
-# Ultrix 2.2 make doesn't expand the value of VPATH.
-srcdir = @srcdir@
-VPATH = @srcdir@
-
-CC = @CC@
-# CC = cc # QNX
-
-CFLAGS = @CFLAGS@
-# CFLAGS = -g2 -5 # QNX
-LDFLAGS = @LDFLAGS@
-# LDFLAGS = -g2 -5 -N64k # QNX
-LEX = @LEX@
-LEXFLAGS=
-YACC = @YACC@
-# YACC = yacc
-YACCFLAGS = -d # -t
-
-CEFLAGS = @CEFLAGS@
-CPFLAGS = @CPFLAGS@
-LDEFLAGS = @LDEFLAGS@
-
-# for gettext (used by fetchmail.c, NOT by GNU gettext)
-localedir = $(datadir)/locale
-
-# How to invoke ranlib. This is only used by the `glob' subdirectory.
-RANLIB = @RANLIB@
-
-# NeXT 1.0a uses an old version of GCC, which required -D__inline=inline.
-# See also `config.h'.
-DEFS = @DEFS@ @EXTRADEFS@ -DLOCALEDIR=\"$(localedir)\"
-# DEFS = -DQNX -DHAVE_CONFIG_H -DHAVE_UNISTD_H -DHAVE_STDARG_H -DSTDC_HEADERS # QNX
-defines = $(DEFS)
-
-# If your system needs extra libraries loaded in, define them here.
-# In particular, add -lresolv if you are running bind 4.9.5
-LOADLIBS = @LIBS@ @INTLLIBS@ @LEXLIB@
-# LOADLIBS = -lsocket3r -lunix3r # QNX
-
-# Extra sources/objects for library functions not provided on the host system.
-EXTRASRC = @EXTRASRC@
-# EXTRASRC = $(srcdir)/strcasecmp.c $(srcdir)/alloca.c # QNX
-EXTRAOBJ = @EXTRAOBJ@ @INTLOBJS@
-# EXTRAOBJ = strcasecmp.o alloca.o getopt.o getopt1.o
-
-DESTDIR =
-
-# Common prefix for machine-independent installed files.
-prefix = @prefix@
-# Common prefix for machine-dependent installed files.
-exec_prefix = @exec_prefix@
-
-# Directory in which to install.
-bindir = @bindir@
-# Directory to install the Info files in.
-infodir = @infodir@
-# Directory to install data files.
-datadir = @datadir@
-# Number to put on the man page filename.
-manext = 1
-# Directory to install the man page in.
-mandir = @mandir@/man$(manext)
-
-# Toplevel build directory
-top_builddir = .
-top_srcdir = @top_srcdir@
-
-# Program to install `make'.
-INSTALL_PROGRAM = @INSTALL_PROGRAM@
-# Program to install the man page.
-INSTALL_DATA = @INSTALL_DATA@
-# Generic install program.
-INSTALL = @INSTALL@
-
-# Program to format Texinfo source into Info files.
-MAKEINFO = makeinfo
-# Program to format Texinfo source into DVI files.
-TEXI2DVI = texi2dvi
-
-# Programs to make tags files.
-ETAGS = etags
-CTAGS = ctags
-
-protobjs = rcfile_y.o rcfile_l.o socket.o getpass.o pop2.o pop3.o imap.o \
- etrn.o odmr.o fetchmail.o idle.o env.o options.o daemon.o driver.o \
- transact.o sink.o rfc822.o smtp.o xmalloc.o uid.o mxget.o md5ify.o \
- cram.o kerberos.o gssapi.o opie.o rpa.o interface.o netrc.o base64.o \
- report.o unmime.o conf.o checkalias.o smbdes.o smbencrypt.o smbmd4.o \
- smbutil.o ipv6-connect.o lock.o
-
-objs = $(protobjs) $(EXTRAOBJ)
-
-srcs = $(srcdir)/socket.c $(srcdir)/getpass.c $(srcdir)/pop2.c \
- $(srcdir)/pop3.c $(srcdir)/imap.c $(srcdir)/etrn.c \
- $(srcdir)/odmr.c $(srcdir)/fetchmail.c $(srcdir)/env.c \
- $(srcdir)/idle.c $(srcdir)/options.c $(srcdir)/daemon.c \
- $(srcdir)/driver.c $(srcdir)/transact.c $(srcdir)/sink.c \
- $(srcdir)/rfc822.c $(srcdir)/smtp.c $(srcdir)/xmalloc.c \
- $(srcdir)/uid.c $(srcdir)/mxget.c $(srcdir)/md5ify.c \
- $(srcdir)/cram.c $(srcdir)/kerberos.c $(srcdir)/gssapi.c \
- $(srcdir)/opie.c $(srcdir)/rpa.c $(srcdir)/interface.c \
- $(srcdir)/netrc.c $(srcdir)/base64.c $(srcdir)/report.c \
- $(srcdir)/unmime.c $(srcdir)/conf.c $(srcdir)/checkalias.c \
- $(srcdir)/smbdes.c $(srcdir)/smbencrypt.c $(srcdir)/smbmd4.c \
- $(srcdir)/smbutil.c $(srcdir)/ipv6-connect.c $(srcdir)/lock.c
-
-.SUFFIXES:
-.SUFFIXES: .o .c .h .y .l .ps .dvi .info .texi
-
-all: fetchmail po
-
-# Some makes apparently use .PHONY as the default goal if it is before `all'.
-.PHONY: all
-
-fetchmail: $(objs) @INTLDEPS@
- $(CC) $(LDEFLAGS) $(LDFLAGS) $(objs) $(LOADLIBS) -o fetchmail
-
-intl:
-@INTLDEPS@: dummy
- cd intl; $(MAKE)
-
-po: dummy
- cd po; $(MAKE)
-
-dummy:
-
-# Tester for address parsing
-rfc822: rfc822.c
- gcc -DMAIN -g rfc822.c -o rfc822
-
-# Stand-alone MIME decoder
-unmime: unmime.c base64.c rfc822.c xmalloc.c report.c
- $(CC) -DSTANDALONE -DHAVE_CONFIG_H -I. -g -o $@ $^
-
-
-# Stand-alone netrc tester
-netrc: netrc.c xmalloc.o report.o
- $(CC) -DSTANDALONE -DHAVE_CONFIG_H -I. -g -o $@ $^
-
-.c.o:
- $(CC) $(defines) -c $(CPFLAGS) -I. -I$(srcdir) -I$(top_builddir)/intl -I$(top_srcdir)/intl $(CEFLAGS) $(CFLAGS) $<
-
-# For some losing Unix makes.
-SHELL = /bin/sh
-@SET_MAKE@
-
-tagsrcs = $(srcs) rcfile_l.c rcfile_y.c
-TAGS: $(tagsrcs)
- $(ETAGS) $(tagsrcs)
-tags: $(tagsrcs)
- $(CTAGS) $(tagsrcs)
-
-.PHONY: install uninstall
-install:
- @echo "Creating installation directories..."
- $(SHELL) ${srcdir}/mkinstalldirs $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)
- @echo "Installing fetchmail binary..."
- $(INSTALL_PROGRAM) ./fetchmail $(DESTDIR)$(bindir)/fetchmail
- @echo "Installing fetchmail configurator..."
- $(INSTALL_PROGRAM) ${srcdir}/fetchmailconf $(DESTDIR)$(bindir)/fetchmailconf
- @echo "Installing manual page..."
- $(INSTALL_DATA) $(srcdir)/fetchmail.man $(DESTDIR)$(mandir)/fetchmail.$(manext)
- rm -f $(DESTDIR)$(mandir)/fetchmailconf.$(manext)
- cd $(DESTDIR)$(mandir) && ln -s fetchmail.$(manext) fetchmailconf.$(manext)
- @echo "Installing language catalogs..."
- -cd intl; $(MAKE) install
- cd po; $(MAKE) install
-
-uninstall:
- rm -f $(DESTDIR)$(bindir)/fetchmail $(DESTDIR)$(bindir)/fetchmailconf
- rm -f $(DESTDIR)$(mandir)/fetchmail.$(manext) $(DESTDIR)$(mandir)/fetchmailconf.$(manext)
- -cd intl; $(MAKE) uninstall
- cd po; $(MAKE) uninstall
-
-.PHONY: clean realclean distclean mostlyclean
-clean:
- -cd intl; $(MAKE) clean
- -rm -f $(top_builddir)/intl/libintl.h # work around GNU gettext brain-damage
- -cd po; $(MAKE) clean
- -rm -f fetchmail *.o core *~ fetchmail.dvi \
- rcfile_l.c rcfile_y.h rcfile_y.c \
- fetchmail.tar fetchmail.tar.gz \
- netrc rfc822 unmime fetchmail-man.html
-
-# This target would also normally invoke the following line, but doing so
-# messes up the RPM build, so the line was disabled.
-# -rm -f config.h config.cache config.status config.log stamp-config
-distclean: clean
- -cd intl; $(MAKE) distclean
- -cd po; $(MAKE) distclean
- -rm -f TAGS tags config.h config.log \
- config.cache stamp-h stamp-h.in
- -rm -f config.status Makefile
-
-realclean: distclean
- -rm -f FAQ FEATURES NOTES MANIFEST
- -rm -f config.cache config.log Makefile
- -rm -f fetchmail-*.tar.gz fetchmail-*.i386.rpm
-
-mostlyclean: clean
-
-# These magic rules are copied from the autoconf documentation
-# except that Harry McGavran says the autoheader call in the third
-# one below is unnecessary and causes problems with cross-platform builds.
-
-${srcdir}/configure: configure.in aclocal.m4
- cd ${srcdir} && @AUTOCONF@
-
-# autoheader might not change config.h.in, so touch a stamp file.
-${srcdir}/config.h.in: stamp-h.in
-
-${srcdir}/stamp-h.in: configure.in aclocal.m4
- cd ${srcdir} && @AUTOHEADER@
- echo timestamp > ${srcdir}/stamp-h.in
-
-config.h: stamp-h
-stamp-h: config.h.in config.status
- ./config.status
-
-Makefile: Makefile.in config.status
- ./config.status
-
-config.status: configure
- ./config.status --recheck
-
-$(srcdir)/aclocal.m4: configure.in
- cd $(srcdir) && @ACLOCAL@
-
-# This tells versions [3.59,3.63) of GNU make not to export all variables.
-.NOEXPORT:
-
-# Special dependencies, not easily handled portably without explicit rules
-rcfile_l.c rcfile_l.h: $(srcdir)/rcfile_l.l
- $(LEX) $(LEXFLAGS) $(srcdir)/rcfile_l.l
- sed <lex.yy.c >rcfile_l.c -e "/lex\\.yy\\.c/s//rcfile_l.c/"
- rm -f lex.yy.c
-rcfile_y.c rcfile_y.h: $(srcdir)/rcfile_y.y
- @echo "expect conflicts: 2 shift/reduce"
- $(YACC) $(YACCFLAGS) $(srcdir)/rcfile_y.y
- mv y.tab.c rcfile_y.c
- mv -f y.tab.h rcfile_y.h
-
-# These must be explicit, because the .c files often don't exist at
-# makefile build time.
-rcfile_l.o: rcfile_l.c config.h fetchmail.h
-rcfile_y.o: rcfile_y.c config.h fetchmail.h
-
-parser = $(srcdir)/rcfile_l.l $(srcdir)/rcfile_y.y
-headers = $(srcdir)/fetchmail.h $(srcdir)/socket.h $(srcdir)/smtp.h \
- $(srcdir)/mx.h $(srcdir)/md5.h \
- $(srcdir)/netrc.h $(srcdir)/tunable.h $(srcdir)/i18n.h \
- $(srcdir)/ntlm.h $(srcdir)/smb.h $(srcdir)/kerberos.h \
- $(srcdir)/smbbyteorder.h $(srcdir)/smbdes.h $(srcdir)/smbencrypt.h \
- $(srcdir)/smbmd4.h
-extra = $(srcdir)/alloca.c $(srcdir)/strcasecmp.c $(srcdir)/strstr.c \
- $(srcdir)/memmove.c $(srcdir)/md5c.c $(srcdir)/getopt.[ch] $(srcdir)/getopt1.c
-docs = $(srcdir)/COPYING $(srcdir)/FEATURES $(srcdir)/fetchmail-features.html \
- $(srcdir)/design-notes.html $(srcdir)/NOTES \
- $(srcdir)/todo.html $(srcdir)/TODO \
- $(srcdir)/INSTALL $(srcdir)/README $(srcdir)/README.SSL \
- $(srcdir)/README.NTLM $(srcdir)/fetchmail.lsm $(srcdir)/NEWS \
- $(srcdir)/*.man $(srcdir)/FAQ $(srcdir)/fetchmail-FAQ.html
-config = $(srcdir)/Makefile.in $(srcdir)/configure.in $(srcdir)/configure \
- $(srcdir)/config.guess $(srcdir)/config.h.in $(srcdir)/config.sub \
- $(srcdir)/acconfig.h $(srcdir)/aclocal.m4 $(srcdir)/fetchmail.spec
-scripts = $(srcdir)/install-sh $(srcdir)/missing $(srcdir)/mkinstalldirs \
- $(srcdir)/specgen.sh $(srcdir)/fetchmailconf
-all = $(docs) $(config) $(srcs) $(parser) $(headers) $(extra) $(scripts) \
- $(srcdir)/rh-config/* $(srcdir)/contrib/*[A-Za-uw-z] \
- $(srcdir)/po/* $(srcdir)/intl $(srcdir)/beos/* ABOUT-NLS $(srcdir)/MANIFEST
-
-fetchmail.spec: Makefile.in
- $(srcdir)/specgen.sh $(VERSION) >fetchmail.spec
-
-MANIFEST: $(srcdir) Makefile.in
- @echo $(all) | tr "[ \t]" '\n' | sed -e '/^\.\//s///' | sort >MANIFEST
- @wc -l MANIFEST
-
-distdocs: FAQ FEATURES NOTES fetchmail-man.html
-
-FAQ: fetchmail-FAQ.html
- echo " (This document was generated from fetchmail-FAQ.html)" >FAQ
- lynx -dump -nolist fetchmail-FAQ.html >>FAQ
-
-FEATURES: fetchmail-features.html
- echo " (This document was generated from fetchmail-features.html)" >FEATURES
- lynx -dump -nolist fetchmail-features.html | grep -v "Back to " >>FEATURES
-
-NOTES: design-notes.html
- echo " (This document was generated from design-notes.html)" >NOTES
- lynx -dump -nolist design-notes.html | grep -v "Back to " >>NOTES
-
-TODO: todo.html
- echo " (This document was generated from todo.html)" >TODO
- lynx -dump -nolist todo.html | grep -v "Back to " >>TODO
-
-# man2html no longer chokes and dies on this man page,
-# but manServer.pl does a much better job.
-fetchmail-man.html: fetchmail.man
- PATH=\${PATH}:$(srcdir)/dist-tools manServer.pl fetchmail.man >fetchmail-man.html
-
-# Make distribution.
-dist: MANIFEST Makefile.in distdocs fetchmail-$(VERSION).tar.gz
- #touch fetchmail.lsm
- #make fetchmail-$(VERSION).tar.gz
- #-cd po; make update-po
- ls -l fetchmail-$(VERSION).tar.gz
- #@echo "Don't forget to build RPMs from root!"
-
-# Firewall against the lossage in autoconf that keeps breaking our build.
-EX = --exclude "fetchmail-$(VERSION)/intl/libintl.h"
-fetchmail-$(VERSION).tar.gz: $(all)
- (cd ..; ln -sf $(shell basename \${PWD}) fetchmail-$(VERSION))
- (cd ..; tar $(EX) -czf fetchmail-$(VERSION).tar.gz `sed <fetchmail-$(VERSION)/MANIFEST s:^:fetchmail-$(VERSION)/:`)
- mv -f ../fetchmail-$(VERSION).tar.gz .
- rm ../fetchmail-$(VERSION)
-
-# The following sets edit modes for GNU EMACS.
-# Local Variables:
-# compile-command:"configure"
-# End:
-
-# Automatically generated dependencies will be put at the end of the makefile.