aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in38
1 files changed, 18 insertions, 20 deletions
diff --git a/Makefile.in b/Makefile.in
index cdf5860d..a5e58e67 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,10 +3,8 @@
# If you're running QNX, we can't assume a working autoconf.
# So just uncomment all the lines marked QNX.
-VERS=4.6.9
-
-PACKAGE = @PACKAGE@
-VERSION = @VERSION@
+PACKAGE = fetchmail
+VERSION = 4.6.9
SUBDIRS = @INTLSUB@ @POSUB@
@@ -38,7 +36,7 @@ RANLIB = @RANLIB@
# See also `config.h'.
DEFS = @DEFS@ @EXTRADEFS@
# DEFS = -DQNX -DHAVE_CONFIG_H -DHAVE_UNISTD_H -DHAVE_STDARG_H -DSTDC_HEADERS # QNX
-defines = -DRELEASE_ID=\"$(VERS)\" $(DEFS)
+defines = $(DEFS)
# If your system needs extra libraries loaded in, define them here.
# In particular, add -lresolv if you are running bind 4.9.5
@@ -179,13 +177,13 @@ realclean: distclean
mostlyclean: clean
-config.status: configure
+config.status: configure Makefile.in
$(srcdir)/configure
config.h: config.status config.h.in
sh config.status; touch config.h
-Makefile: config.status Makefile.in
+Makefile: config.status
sh config.status
configure: configure.in
@@ -253,28 +251,28 @@ NOTES: design-notes.html
dist: Makefile.in
rm -f MANIFEST; make MANIFEST;
touch fetchmail.lsm
- make fetchmail-$(VERS).tar.gz
- lsmgen.sh $(VERS) `wc -c fetchmail-$(VERS).tar.gz` >fetchmail.lsm
- make fetchmail-$(VERS).tar.gz
- ls -l fetchmail-$(VERS).tar.gz
+ make fetchmail-$(VERSION).tar.gz
+ lsmgen.sh $(VERSION) `wc -c fetchmail-$(VERSION).tar.gz` >fetchmail.lsm
+ make fetchmail-$(VERSION).tar.gz
+ ls -l fetchmail-$(VERSION).tar.gz
@echo "Don't forget to build RPMs from root!"
-fetchmail-$(VERS).tar.gz: $(all)
- (cd ..; ln -sf fetchmail fetchmail-$(VERS))
- (cd ..; tar -czf fetchmail-$(VERS).tar.gz `sed <fetchmail-$(VERS)/MANIFEST s:^:fetchmail-$(VERS)/:`)
- mv -f ../fetchmail-$(VERS).tar.gz .
- rm ../fetchmail-$(VERS)
+fetchmail-$(VERSION).tar.gz: $(all)
+ (cd ..; ln -sf fetchmail fetchmail-$(VERSION))
+ (cd ..; tar -czf fetchmail-$(VERSION).tar.gz `sed <fetchmail-$(VERSION)/MANIFEST s:^:fetchmail-$(VERSION)/:`)
+ mv -f ../fetchmail-$(VERSION).tar.gz .
+ rm ../fetchmail-$(VERSION)
# Make RPMs. You need to be root to make this work
RPMROOT=/usr/src/redhat
RPM = rpm
RPMFLAGS = -ba
rpm: dist
- cp fetchmail-$(VERS).tar.gz fetchmail.gif $(RPMROOT)/SOURCES;
- $(srcdir)/specgen.sh $(VERS) >$(RPMROOT)/SPECS/fetchmail.spec
+ cp fetchmail-$(VERSION).tar.gz fetchmail.gif $(RPMROOT)/SOURCES;
+ $(srcdir)/specgen.sh $(VERSION) >$(RPMROOT)/SPECS/fetchmail.spec
cd $(RPMROOT)/SPECS; $(RPM) $(RPMFLAGS) fetchmail.spec
- cp $(RPMROOT)/RPMS/`arch|sed 's/i[4-9]86/i386/'`/fetchmail-$(VERS)*.rpm $(srcdir)
- cp $(RPMROOT)/SRPMS/fetchmail-$(VERS)*.src.rpm $(srcdir)
+ cp $(RPMROOT)/RPMS/`arch|sed 's/i[4-9]86/i386/'`/fetchmail-$(VERSION)*.rpm $(srcdir)
+ cp $(RPMROOT)/SRPMS/fetchmail-$(VERSION)*.src.rpm $(srcdir)
# The following sets edit modes for GNU EMACS.
# Local Variables: