aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 1faa4d1d..55139d95 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -22,6 +22,9 @@ YACC = @YACC@
# YACC = yacc
YACCFLAGS = -dt
+CEFLAGS = @CEFLAGS@
+LDEFLAGS = @LDEFLAGS@
+
# How to invoke ranlib. This is only used by the `glob' subdirectory.
RANLIB = @RANLIB@
@@ -101,14 +104,14 @@ all: fetchmail
.PHONY: all
fetchmail: $(objs)
- $(CC) $(LDFLAGS) $(objs) $(LOADLIBS) -o fetchmail
+ $(CC) $(LDEFLAGS) $(LDFLAGS) $(objs) $(LOADLIBS) -o fetchmail
# Tester for address parsing
rfc822: rfc822.c
gcc -DTESTMAIN -g rfc822.c -o rfc822
.c.o:
- $(CC) $(defines) -c -I$(srcdir) -I. $(CFLAGS) $<
+ $(CC) $(defines) -c -I$(srcdir) -I. $(CEFLAGS) $(CFLAGS) $<
# For some losing Unix makes.
SHELL = /bin/sh