aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6166c4a3..58892b41 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -71,7 +71,7 @@ fetchmail.spec: Makefile.in specgen.sh
$(srcdir)/specgen.sh $(VERSION) >fetchmail.spec
DISTDOCS= FAQ FEATURES NOTES OLDNEWS fetchmail-man.html \
- fetchmail-FAQ.html esrs-design-notes.html todo.html \
+ fetchmail-FAQ.html design-notes.html esrs-design-notes.html todo.html \
fetchmail-features.html README.SSL README.NTLM
# extra directories to ship
@@ -86,8 +86,13 @@ FAQ: fetchmail-FAQ.html
FEATURES: fetchmail-features.html
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/fetchmail-features.html >$@ || { rm -f $@ ; exit 1 ; }
-NOTES: esrs-design-notes.html
- AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/esrs-design-notes.html >$@ || { rm -f $@ ; exit 1 ; }
+NOTES: design-notes.html esrs-design-notes.html
+ echo "This file contains two articles reformatted from HTML." > $@ \
+ && echo "------------------------------------------------------" >> $@ \
+ && echo "" >> $@ \
+ && AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txtx $(srcdir)/design-notes.html >>$@ \
+ && AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/esrs-design-notes.html >>$@ \
+ || { rm -f $@ ; exit 1 ; }
TODO: todo.html
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/todo.html >$@ || { rm -f $@ ; exit 1 ; }