aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/Makefile.am b/Makefile.am
index dc0c365f..0d12ec82 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -113,12 +113,14 @@ EXTRA_DIST+= $(DISTDOCS) fetchmail.spec $(distdirs) ucs/README.svn \
m4-local/ac-archive-license.txt \
m4-local/ac_ma_search_package.m4 \
m4-local/autobuild.m4 \
- t.smoke t.rc
+ t.smoke t.rc \
+ dist-tools/html2txt \
+ dist-tools/manServer.pl
fetchmailconf:
( echo '#! /bin/sh' && echo 'exec @PYTHON@ @pythondir@/fetchmailconf.py "$$@"' ) >$@ || { rm -f $@ ; exit 1; }
-FAQ: fetchmail-FAQ.html
+FAQ: fetchmail-FAQ.html $(srcdir)/dist-tools/html2txt
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/fetchmail-FAQ.html >$@ || { rm -f $@ ; exit 1 ; }
fetchmail-FAQ.pdf: fetchmail-FAQ.html fetchmail-FAQ.book bighand.png
@@ -126,10 +128,10 @@ fetchmail-FAQ.pdf: fetchmail-FAQ.html fetchmail-FAQ.book bighand.png
htmldoc --logoimage $(srcdir)/bighand.png --batch $(srcdir)/fetchmail-FAQ.book
rm -f fetchmail-FAQ-print.html
-FEATURES: fetchmail-features.html
+FEATURES: fetchmail-features.html $(srcdir)/dist-tools/html2txt
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/fetchmail-features.html >$@ || { rm -f $@ ; exit 1 ; }
-NOTES: design-notes.html esrs-design-notes.html
+NOTES: design-notes.html esrs-design-notes.html $(srcdir)/dist-tools/html2txt
echo "This file contains two articles reformatted from HTML." > $@ \
&& echo "------------------------------------------------------" >> $@ \
&& echo "" >> $@ \
@@ -137,10 +139,10 @@ NOTES: design-notes.html esrs-design-notes.html
&& AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/esrs-design-notes.html >>$@ \
|| { rm -f $@ ; exit 1 ; }
-TODO: todo.html
+TODO: todo.html $(srcdir)/dist-tools/html2txt
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/todo.html >$@ || { rm -f $@ ; exit 1 ; }
-fetchmail-man.html: fetchmail.man
+fetchmail-man.html: fetchmail.man $(srcdir)/dist-tools/manServer.pl
env - PATH=$$PATH $(srcdir)/dist-tools/manServer.pl $(srcdir)/fetchmail.man >$@ \
|| { rm -f $@ ; exit 1 ; }