aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 083c5340..d7d0320c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,7 +47,7 @@ DEPENDENCIES= libfm.a $(LIBOBJS)
check_PROGRAMS=
-TESTS= t.smoke t.validate-xhtml10 t.validate-xhtml t.x509_name_match t.realpath
+TESTS= t.smoke t.validate-xhtml10 t.validate-xhtml t.x509_name_match t.realpath t.tls-aux
LOG_COMPILER= env LC_ALL=C TZ=UTC $(SHELL)
if NEED_TRIO
@@ -102,8 +102,10 @@ if NEED_GETADDRINFO
fetchmail_SOURCES += libesmtp/getaddrinfo.h libesmtp/getaddrinfo.c
endif
+tls_aux_SOURCES = tls-aux.c
+
check_PROGRAMS += rfc822 unmime netrc rfc2047e mxget rfc822valid \
- x509_name_match fm_realpath
+ x509_name_match fm_realpath tls-aux
fm_realpath_CFLAGS= -DTEST
@@ -113,6 +115,8 @@ rfc822valid_CFLAGS= -DTEST
rfc822_CFLAGS= -DMAIN
+tls_aux_CFLAGS= -DTEST
+
x509_name_match_CFLAGS= -DTEST
unmime_SOURCES= unmime.c