aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--INSTALL29
-rw-r--r--Makefile.in6
-rw-r--r--daemon.c32
-rw-r--r--fetchmail.c62
-rw-r--r--fetchmail.h62
-rw-r--r--fetchmail.man44
-rw-r--r--getpass.c40
-rw-r--r--md5.h25
-rw-r--r--md5c.c25
-rw-r--r--md5global.h21
-rw-r--r--md5ify.c34
-rw-r--r--options.c58
-rw-r--r--pop2.c57
-rw-r--r--pop3.c57
-rw-r--r--rcfile_l.l53
-rw-r--r--rcfile_y.y53
-rw-r--r--socket.c53
-rw-r--r--xmalloc.c31
18 files changed, 54 insertions, 688 deletions
diff --git a/INSTALL b/INSTALL
index fdf5a8a7..acdc24fd 100644
--- a/INSTALL
+++ b/INSTALL
@@ -1,33 +1,6 @@
INSTALL Instructions for Popclient
- $Log: INSTALL,v $
- Revision 1.1 1996/06/28 14:09:41 esr
- Initial revision
-
- Revision 1.2 1995/08/10 00:32:17 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.1 1995/08/09 01:32:40 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
-
-
-Installing popclient is easier than ever. From within this directory,
-type:
+Installing popclient is easy. From within this directory, type:
./configure
diff --git a/Makefile.in b/Makefile.in
index 83171e55..e3507ca3 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -3,6 +3,10 @@
# Carl Harris, ceharris@mal.com
#
# $Log: Makefile.in,v $
+# Revision 1.3 1996/06/28 14:53:20 esr
+# Licensing and copyright changes pursuant to Carl Harris handing me the
+# baton.
+#
# Revision 1.2 1996/06/26 19:08:55 esr
# This is what I sent Harris.
#
@@ -240,7 +244,7 @@ extra = $(srcdir)/alloca.c $(srcdir)/bzero.[ch] $(srcdir)/errorcodes \
$(srcdir)/strcasecmp.c $(srcdir)/strdup.c
docs = $(srcdir)/README $(srcdir)/INSTALL $(srcdir)/RFC/*.txt \
$(srcdir)/*.man $(srcdir)/*.texi $(srcdir)/*.info \
- $(srcdir)/sample.poprc $(srcdir)/TODO
+ $(srcdir)/sample.poprc $(srcdir)/NEWS
config = $(srcdir)/Makefile.in $(srcdir)/configure.in $(srcdir)/config.guess \
$(srcdir)/config.h.in $(srcdir)/config.sub
scripts = $(srcdir)/install.sh $(srcdir)/mkinstalldirs
diff --git a/daemon.c b/daemon.c
index 0776d062..66218b57 100644
--- a/daemon.c
+++ b/daemon.c
@@ -1,18 +1,6 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
@@ -24,20 +12,6 @@
turn a process into a daemon for POSIX, SysV, and
BSD systems.
- $Log: daemon.c,v $
- Revision 1.3 1996/06/27 19:22:31 esr
- Sent to ceharris.
-
- Revision 1.2 1996/06/26 19:08:57 esr
- This is what I sent Harris.
-
- Revision 1.1 1996/06/25 14:32:01 esr
- Initial revision
-
- Revision 1.1 1995/08/14 18:36:38 ceharris
- Patches to support POP3's LAST command.
- Final revisions for beta3 release.
-
***********************************************************************/
diff --git a/fetchmail.c b/fetchmail.c
index c85aec3a..a92991ba 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -1,69 +1,15 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
/***********************************************************************
module: popclient.c
project: popclient
programmer: Carl Harris, ceharris@mal.com
+ Extensively hacked and improved by esr.
description: main driver module for popclient
- $Log: fetchmail.c,v $
- Revision 1.3 1996/06/27 19:22:32 esr
- Sent to ceharris.
-
- Revision 1.2 1996/06/26 19:08:59 esr
- This is what I sent Harris.
-
- Revision 1.1 1996/06/24 18:32:00 esr
- Initial revision
-
- Revision 1.7 1995/09/07 22:37:34 ceharris
- Preparation for 3.0b4 release.
-
- Revision 1.6 1995/08/14 18:36:43 ceharris
- Patches to support POP3's LAST command.
- Final revisions for beta3 release.
-
- Revision 1.5 1995/08/10 00:32:39 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.4 1995/08/09 01:32:56 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
- Revision 1.3 1995/08/08 01:01:25 ceharris
- Added GNU-style long options processing.
- Fixed password in 'ps' output problem.
- Fixed various RCS tag blunders.
- Integrated .poprc parser, lexer, etc into Makefile processing.
-
***********************************************************************/
diff --git a/fetchmail.h b/fetchmail.h
index 0e85fc8e..c825f770 100644
--- a/fetchmail.h
+++ b/fetchmail.h
@@ -1,70 +1,14 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
-
/***********************************************************************
module: popclient.h
project: popclient
programmer: Carl Harris, ceharris@mal.com
description: global constant, type, and variable definitions.
- $Log: fetchmail.h,v $
- Revision 1.3 1996/06/27 19:22:33 esr
- Sent to ceharris.
-
- Revision 1.2 1996/06/26 19:08:59 esr
- This is what I sent Harris.
-
- Revision 1.1 1996/06/24 18:14:08 esr
- Initial revision
-
- Revision 1.6 1995/09/07 22:37:35 ceharris
- Preparation for 3.0b4 release.
-
- Revision 1.5 1995/08/14 18:36:44 ceharris
- Patches to support POP3's LAST command.
- Final revisions for beta3 release.
-
- Revision 1.4 1995/08/10 00:32:40 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.3 1995/08/09 01:32:57 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
- Revision 1.2 1995/08/08 01:01:27 ceharris
- Added GNU-style long options processing.
- Fixed password in 'ps' output problem.
- Fixed various RCS tag blunders.
- Integrated .poprc parser, lexer, etc into Makefile processing.
-
***********************************************************************/
diff --git a/fetchmail.man b/fetchmail.man
index 8eca7854..7c36ed8a 100644
--- a/fetchmail.man
+++ b/fetchmail.man
@@ -1,44 +1,6 @@
-\. /* Copyright 1993-95 by Carl Harris, Jr.
-\. * All rights reserved
-\. *
-\. * Distribute freely, except: don't remove my name from the source or
-\. * documentation (don't take credit for my work), mark your changes (don't
-\. * get me blamed for your possible bugs), don't alter or remove this
-\. * notice. May be sold if buildable source is provided to buyer. No
-\. * warrantee of any kind, express or implied, is included with this
-\. * software; use at your own risk, responsibility for damages (if any) to
-\. * anyone resulting from the use of this software rests entirely with the
-\. * user.
-\. *
-\. * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
-\. * I'll try to keep a version up to date. I can be reached as follows:
-\. * Carl Harris <ceharris@vt.edu>
-\. */
-\.
-\. $Log: fetchmail.man,v $
-\. Revision 1.3 1996/06/27 19:22:33 esr
-\. Sent to ceharris.
-\.
-\. Revision 1.2 1996/06/26 19:09:00 esr
-\. This is what I sent Harris.
-\.
-\. Revision 1.1 1996/06/24 19:30:36 esr
-\. Initial revision
-\.
-\. Revision 1.4 1995/09/07 22:53:49 ceharris
-\. One last bit of crap before the 3.0b4 release
-\.
-\. Revision 1.3 1995/08/14 18:36:46 ceharris
-\. Patches to support POP3's LAST command.
-\. Final revisions for beta3 release.
-\.
-\. Revision 1.2 1995/08/08 01:01:29 ceharris
-\. Added GNU-style long options processing.
-\. Fixed password in 'ps' output problem.
-\. Fixed various RCS tag blunders.
-\. Integrated .poprc parser, lexer, etc into Makefile processing.
-\.
-\.
+.\" Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+.\" All rights reserved.
+.\" For license terms, see the file COPYING in this directory.
.TH popclient LOCAL
.SH NAME
popclient \- retrieve mail from a mailserver using Post Office Protocol.
diff --git a/getpass.c b/getpass.c
index c5fe4829..08649fbf 100644
--- a/getpass.c
+++ b/getpass.c
@@ -1,48 +1,14 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
-
/***********************************************************************
module: getpass.c
project: popclient
programmer: Carl Harris, ceharris@mal.com
description: getpass() replacement which allows for long passwords.
- $Log: getpass.c,v $
- Revision 1.1 1996/06/28 14:33:54 esr
- Initial revision
-
- Revision 1.4 1995/08/10 00:32:27 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.3 1995/08/08 01:01:19 ceharris
- Added GNU-style long options processing.
- Fixed password in 'ps' output problem.
- Fixed various RCS tag blunders.
- Integrated .poprc parser, lexer, etc into Makefile processing.
-
***********************************************************************/
#include <config.h>
diff --git a/md5.h b/md5.h
index 848894ac..f9deb4ef 100644
--- a/md5.h
+++ b/md5.h
@@ -1,28 +1,3 @@
-/*
- * md5.h header file for MD5 module used by popclient
- *
- * $Log: md5.h,v $
- * Revision 1.1 1996/06/28 14:34:58 esr
- * Initial revision
- *
- * Revision 1.2 1995/08/10 00:32:28 ceharris
- * Preparation for 3.0b3 beta release:
- * - added code for --kill/--keep, --limit, --protocol, --flush
- * options; --pop2 and --pop3 options now obsoleted by --protocol.
- * - added support for APOP authentication, including --with-APOP
- * argument for configure.
- * - provisional and broken support for RPOP
- * - added buffering to SockGets and SockRead functions.
- * - fixed problem of command-line options not being correctly
- * carried into the merged options record.
- *
- * Revision 1.1 1995/08/09 14:27:22 ceharris
- * First revision popclient MD5 support for APOP. The MD5 code is
- * provided by RSA Data Security. See notice below.
- *
- *
- */
-
/* MD5.H - header file for MD5C.C
*/
diff --git a/md5c.c b/md5c.c
index 9488fa71..43d85e68 100644
--- a/md5c.c
+++ b/md5c.c
@@ -1,28 +1,3 @@
-/*
- * md5c.c MD5 support used by popclient.
- *
- * $Log: md5c.c,v $
- * Revision 1.1 1996/06/28 14:35:47 esr
- * Initial revision
- *
- * Revision 1.2 1995/08/10 00:32:30 ceharris
- * Preparation for 3.0b3 beta release:
- * - added code for --kill/--keep, --limit, --protocol, --flush
- * options; --pop2 and --pop3 options now obsoleted by --protocol.
- * - added support for APOP authentication, including --with-APOP
- * argument for configure.
- * - provisional and broken support for RPOP
- * - added buffering to SockGets and SockRead functions.
- * - fixed problem of command-line options not being correctly
- * carried into the merged options record.
- *
- * Revision 1.1 1995/08/09 14:27:23 ceharris
- * First revision popclient MD5 support for APOP. The MD5 code is
- * provided by RSA Data Security. See notice below.
- *
- *
- */
-
/* MD5C.C - RSA Data Security, Inc., MD5 message-digest algorithm
*/
diff --git a/md5global.h b/md5global.h
index ba261587..99eb0a01 100644
--- a/md5global.h
+++ b/md5global.h
@@ -1,21 +1,8 @@
-/*
- * md5global.h Global declarations for MD5 module used by popclient
- *
- * $Log: md5global.h,v $
- * Revision 1.1 1996/06/28 14:36:11 esr
- * Initial revision
- *
- * Revision 1.2 1995/08/10 00:32:31 ceharris
- * Preparation for 3.0b3 beta release:
- * - added code for --kill/--keep, --limit, --protocol, --flush
- * options; --pop2 and --pop3 options now obsoleted by --protocol.
- * - added support for APOP authentication, including --with-APOP
- * argument for configure.
- * - provisional and broken support for RPOP
- * - added buffering to SockGets and SockRead functions.
- * - fixed problem of command-line options not being correctly
- * carried into the merged options record.
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*
+ * md5global.h Global declarations for MD5 module used by popclient
*
*/
diff --git a/md5ify.c b/md5ify.c
index b090687f..da4337be 100644
--- a/md5ify.c
+++ b/md5ify.c
@@ -1,42 +1,14 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
-
/***********************************************************************
module: md5ify.c
project: popclient
programmer: Carl Harris, ceharris@mal.com
description: Simple interface to MD5 module.
- $Log: md5ify.c,v $
- Revision 1.1 1996/06/28 14:36:57 esr
- Initial revision
-
- Revision 1.1 1995/08/10 00:32:33 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
***********************************************************************/
#include <stdio.h>
diff --git a/options.c b/options.c
index 199a182f..1fcb663f 100644
--- a/options.c
+++ b/options.c
@@ -1,18 +1,6 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
/***********************************************************************
@@ -20,46 +8,6 @@
project: popclient
programmer: Carl Harris, ceharris@mal.com
description: command-line option processing
-
- $Log: options.c,v $
- Revision 1.3 1996/06/27 19:22:32 esr
- Sent to ceharris.
-
- Revision 1.2 1996/06/26 19:08:57 esr
- This is what I sent Harris.
-
- Revision 1.1 1996/06/24 18:11:08 esr
- Initial revision
-
- Revision 1.4 1995/08/14 18:36:39 ceharris
- Patches to support POP3's LAST command.
- Final revisions for beta3 release.
-
- Revision 1.3 1995/08/10 00:32:34 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.2 1995/08/09 01:32:51 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
- Revision 1.1 1995/08/08 01:01:21 ceharris
- Added GNU-style long options processing.
- Fixed password in 'ps' output problem.
- Fixed various RCS tag blunders.
- Integrated .poprc parser, lexer, etc into Makefile processing.
***********************************************************************/
diff --git a/pop2.c b/pop2.c
index 3709d8e8..503f92f4 100644
--- a/pop2.c
+++ b/pop2.c
@@ -1,64 +1,15 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
-
/***********************************************************************
module: pop2.c
project: popclient
programmer: Carl Harris, ceharris@mal.com
+ Hacks and bug fixes by esr.
description: POP2 client code.
- $Log: pop2.c,v $
- Revision 1.2 1996/06/26 19:08:57 esr
- This is what I sent Harris.
-
- Revision 1.1 1996/06/24 19:00:51 esr
- Initial revision
-
- Revision 1.6 1995/08/14 18:36:40 ceharris
- Patches to support POP3's LAST command.
- Final revisions for beta3 release.
-
- Revision 1.5 1995/08/10 00:32:36 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.4 1995/08/09 01:32:53 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
- Revision 1.3 1995/08/08 01:01:22 ceharris
- Added GNU-style long options processing.
- Fixed password in 'ps' output problem.
- Fixed various RCS tag blunders.
- Integrated .poprc parser, lexer, etc into Makefile processing.
-
***********************************************************************/
#include <config.h>
diff --git a/pop3.c b/pop3.c
index 4eb8870e..b86ca79e 100644
--- a/pop3.c
+++ b/pop3.c
@@ -1,64 +1,15 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
-
/***********************************************************************
module: pop3.c
project: popclient
programmer: Carl Harris, ceharris@mal.com
+ Hacks and bug fixes by esr.
description: POP3 client code.
- $Log: pop3.c,v $
- Revision 1.2 1996/06/26 19:08:58 esr
- This is what I sent Harris.
-
- Revision 1.1 1996/06/24 18:56:35 esr
- Initial revision
-
- Revision 1.6 1995/08/14 18:36:42 ceharris
- Patches to support POP3's LAST command.
- Final revisions for beta3 release.
-
- Revision 1.5 1995/08/10 00:32:38 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.4 1995/08/09 01:32:54 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
- Revision 1.3 1995/08/08 01:01:24 ceharris
- Added GNU-style long options processing.
- Fixed password in 'ps' output problem.
- Fixed various RCS tag blunders.
- Integrated .poprc parser, lexer, etc into Makefile processing.
-
***********************************************************************/
#include <config.h>
diff --git a/rcfile_l.l b/rcfile_l.l
index 6d932015..1968b994 100644
--- a/rcfile_l.l
+++ b/rcfile_l.l
@@ -1,62 +1,17 @@
%{
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
-
/***********************************************************************
module: poprc_l.l
project: popclient
programmer: Carl Harris, ceharris@mal.com
+ Extensively hacked by esr.
description: .poprc lexer
- $Log: rcfile_l.l,v $
- Revision 1.2 1996/06/26 19:09:01 esr
- This is what I sent Harris.
-
- Revision 1.1 1996/06/24 18:16:08 esr
- Initial revision
-
- Revision 1.4 1995/08/10 00:32:43 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.3 1995/08/09 01:33:01 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
- Revision 1.2 1995/08/08 01:01:34 ceharris
- Added GNU-style long options processing.
- Fixed password in 'ps' output problem.
- Fixed various RCS tag blunders.
- Integrated .poprc parser, lexer, etc into Makefile processing.
-
***********************************************************************/
#include <config.h>
diff --git a/rcfile_y.y b/rcfile_y.y
index 07d773ce..c2637a04 100644
--- a/rcfile_y.y
+++ b/rcfile_y.y
@@ -1,61 +1,16 @@
%{
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
-
/***********************************************************************
module: poprc_y.y
project: popclient
programmer: Carl Harris, ceharris@mal.com
+ Extensively hacked and fixed by esr.
description: .poprc parser
- $Log: rcfile_y.y,v $
- Revision 1.2 1996/06/26 19:09:01 esr
- This is what I sent Harris.
-
- Revision 1.1 1996/06/24 18:17:24 esr
- Initial revision
-
- Revision 1.4 1995/08/10 00:32:45 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.3 1995/08/09 01:33:02 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
- Revision 1.2 1995/08/08 01:01:36 ceharris
- Added GNU-style long options processing.
- Fixed password in 'ps' output problem.
- Fixed various RCS tag blunders.
- Integrated .poprc parser, lexer, etc into Makefile processing.
-
***********************************************************************/
#include <config.h>
diff --git a/socket.c b/socket.c
index fdb7f405..acb8686f 100644
--- a/socket.c
+++ b/socket.c
@@ -1,61 +1,14 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
-
/***********************************************************************
module: socket.c
project: popclient
programmer: Carl Harris, ceharris@mal.com
description: socket library functions
- $Log: socket.c,v $
- Revision 1.1 1996/06/28 14:48:28 esr
- Initial revision
-
- Revision 1.6 1995/08/14 18:36:48 ceharris
- Patches to support POP3's LAST command.
- Final revisions for beta3 release.
-
- Revision 1.5 1995/08/10 00:32:47 ceharris
- Preparation for 3.0b3 beta release:
- - added code for --kill/--keep, --limit, --protocol, --flush
- options; --pop2 and --pop3 options now obsoleted by --protocol.
- - added support for APOP authentication, including --with-APOP
- argument for configure.
- - provisional and broken support for RPOP
- - added buffering to SockGets and SockRead functions.
- - fixed problem of command-line options not being correctly
- carried into the merged options record.
-
- Revision 1.4 1995/08/09 01:33:05 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
- Revision 1.3 1995/08/08 01:01:37 ceharris
- Added GNU-style long options processing.
- Fixed password in 'ps' output problem.
- Fixed various RCS tag blunders.
- Integrated .poprc parser, lexer, etc into Makefile processing.
-
***********************************************************************/
#include <config.h>
diff --git a/xmalloc.c b/xmalloc.c
index ffae9dd9..f9918e9c 100644
--- a/xmalloc.c
+++ b/xmalloc.c
@@ -1,18 +1,6 @@
-/* Copyright 1993-95 by Carl Harris, Jr.
- * All rights reserved
- *
- * Distribute freely, except: don't remove my name from the source or
- * documentation (don't take credit for my work), mark your changes (don't
- * get me blamed for your possible bugs), don't alter or remove this
- * notice. May be sold if buildable source is provided to buyer. No
- * warrantee of any kind, express or implied, is included with this
- * software; use at your own risk, responsibility for damages (if any) to
- * anyone resulting from the use of this software rests entirely with the
- * user.
- *
- * Send bug reports, bug fixes, enhancements, requests, flames, etc., and
- * I'll try to keep a version up to date. I can be reached as follows:
- * Carl Harris <ceharris@mal.com>
+/* Copyright 1993-95 by Carl Harris, Jr. Copyright 1996 by Eric S. Raymond
+ * All rights reserved.
+ * For license terms, see the file COPYING in this directory.
*/
/***********************************************************************
@@ -21,19 +9,6 @@
programmer: Carl Harris, ceharris@mal.com
description: malloc wrapper.
- $Log: xmalloc.c,v $
- Revision 1.1 1996/06/28 14:50:30 esr
- Initial revision
-
- Revision 1.1 1995/08/09 01:33:08 ceharris
- Version 3.0 beta 2 release.
- Added
- - .poprc functionality
- - GNU long options
- - multiple servers on the command line.
- Fixed
- - Passwords showing up in ps output.
-
***********************************************************************/