aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.am8
-rw-r--r--NEWS2
-rw-r--r--fetchmail-FAQ.book3
-rwxr-xr-xspecgen.sh1
4 files changed, 13 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 474ecc44..cc55605d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -96,9 +96,10 @@ fetchmail.spec: Makefile.in specgen.sh
$(srcdir)/specgen.sh $(VERSION) >fetchmail.spec
DISTDOCS= BUGS FAQ FEATURES NOTES OLDNEWS fetchmail-man.html \
- fetchmail-FAQ.html design-notes.html esrs-design-notes.html todo.html \
+ design-notes.html esrs-design-notes.html todo.html \
fetchmail-features.html README.SSL README.NTLM \
README.packaging \
+ fetchmail-FAQ.book fetchmail-FAQ.pdf fetchmail-FAQ.html \
fetchmail-SA-2005-01.txt \
fetchmail-SA-2005-02.txt
@@ -119,6 +120,11 @@ fetchmailconf:
FAQ: fetchmail-FAQ.html
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/fetchmail-FAQ.html >$@ || { rm -f $@ ; exit 1 ; }
+fetchmail-FAQ.pdf: fetchmail-FAQ.html fetchmail-FAQ.book bighand.png
+ $(AWK) '/^[ \t]*<h1/ {sec++; } {if (sec < 2 || sec > 3) print $0;}' <$(srcdir)/fetchmail-FAQ.html >fetchmail-FAQ-print.html
+ htmldoc --logoimage $(srcdir)/bighand.png --batch $(srcdir)/fetchmail-FAQ.book
+ rm -f fetchmail-FAQ-print.html
+
FEATURES: fetchmail-features.html
AWK=$(AWK) $(SHELL) $(srcdir)/dist-tools/html2txt $(srcdir)/fetchmail-features.html >$@ || { rm -f $@ ; exit 1 ; }
diff --git a/NEWS b/NEWS
index bc6e788e..218c9c05 100644
--- a/NEWS
+++ b/NEWS
@@ -300,6 +300,8 @@ fetchmail 6.3.0 (not yet released officially):
* Fix installation without Python. Sunil Shetye, reported by Peter Church. (MA)
* Update Japanese translation. Fixes Bug#329342, Takeshi Hamasaki. (MA)
* Fix imap.c size safeguard that broke on x86_64 architecture. Matthias Andree
+* The FAQ is now available for duplex DIN A4 printing in PDF format.
+ Don't bother to ask for a Letter version, I don't care. Matthias Andree
# INTERNAL CHANGES
* Switched to automake. Matthias Andree.
diff --git a/fetchmail-FAQ.book b/fetchmail-FAQ.book
new file mode 100644
index 00000000..db6a01a2
--- /dev/null
+++ b/fetchmail-FAQ.book
@@ -0,0 +1,3 @@
+#HTMLDOC 1.8.24 Open Source
+-t pdf14 -f fetchmail-FAQ.pdf --book --toclevels 2 --no-numbered --toctitle "Table of Contents" --title --linkstyle underline --size A4 --left 1.00in --right 0.50in --top 0.50in --bottom 0.50in --header .tl --footer h.1 --nup 1 --tocheader .tl --tocfooter ..i --duplex --portrait --color --no-pscommands --no-xrxcomments --compression=9 --jpeg=0 --fontsize 10.5 --fontspacing 1.2 --headingfont Helvetica --bodyfont Times --headfootsize 10.5 --headfootfont Times-Bold --charset iso-8859-1 --links --no-embedfonts --pagemode document --pagelayout single --firstpage p1 --pageeffect none --pageduration 10 --effectduration 1.0 --encryption --permissions print --permissions no-modify --permissions copy --permissions annotate --owner-password "" --user-password "" --browserwidth 680 --strict --linkcolor blue
+fetchmail-FAQ-print.html
diff --git a/specgen.sh b/specgen.sh
index fef5e41e..cb042ab3 100755
--- a/specgen.sh
+++ b/specgen.sh
@@ -187,6 +187,7 @@ rm -rf \$RPM_BUILD_ROOT
%doc contrib
%doc fetchmail-features.html fetchmail-FAQ.html esrs-design-notes.html
%doc design-notes.html
+%doc fetchmail-FAQ.pdf
%attr(644, root, man) %{_mandir}/man1/fetchmail.1*
%attr(755, root, root) %{_bindir}/fetchmail
%attr(644,root,root) %{_datadir}/locale/*/LC_MESSAGES/fetchmail.mo