aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in12
1 files changed, 10 insertions, 2 deletions
diff --git a/Makefile.in b/Makefile.in
index 423498a9..9b3a5f85 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -168,7 +168,7 @@ clean:
-rm -f fetchmail *.o core fetchmail.dvi \
rcfile_l.c rcfile_y.h rcfile_y.c \
fetchmail.tar fetchmail.tar.gz \
- netrc rfc822 unmime
+ netrc rfc822 unmime fetchmail-man.html
distclean: clean
@POMAKE@ distclean
@@ -253,8 +253,16 @@ NOTES: design-notes.html
echo " (This document was generated from design-notes.html)" >NOTES
lynx -dump -nolist design-notes.html | grep -v "Back to " >NOTES
+# man2html chokes and dies on this man page
+fetchmail-man.html: fetchmail.man
+ echo "<pre>" >fetchmail-man.html
+ groff -man -Tascii -P-b -P-u fetchmail.man >>fetchmail-man.html
+ echo "</pre>" >>fetchmail-man.html
+
# Make distribution, update LSM with proper size, remake distribution
-dist: Makefile.in
+# (Making fetchmail-man.html is a kluge to ensure that it will be
+# available when I upload the distribution.)
+dist: Makefile.in fetchmail-man.html
rm -f MANIFEST; make MANIFEST;
touch fetchmail.lsm
make fetchmail-$(VERSION).tar.gz