aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS1
-rwxr-xr-xdist-tools/getstats.py2
2 files changed, 2 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index 4e741555..ac5d087f 100644
--- a/NEWS
+++ b/NEWS
@@ -109,6 +109,7 @@ fetchmail-6.4.25 (not yet released):
# CHANGES
* fetchmail can now be used with wolfSSL 5's OpenSSL compatibility layer,
see README.SSL. This is considered experimental. Feedback solicited.
+* The getstats.py dist-tool now counts lines of .ac and .am files.
--------------------------------------------------------------------------------
fetchmail-6.4.24 (released 2021-11-20, 30218 LoC):
diff --git a/dist-tools/getstats.py b/dist-tools/getstats.py
index ad52f464..4c45318b 100755
--- a/dist-tools/getstats.py
+++ b/dist-tools/getstats.py
@@ -12,7 +12,7 @@ from datetime import date
# Get version and date
with tempfile.TemporaryDirectory() as tmpdirname:
subprocess.check_call("git archive --format=tar HEAD | ( cd {} && tar -xf -)".format(tmpdirname), shell=True)
- LOC = subprocess.getoutput("cat {0}/*.[chly] {0}/*.py 2>/dev/null | wc -l".format(tmpdirname)).strip()
+ LOC = subprocess.getoutput("cat {0}/*.[chly] {0}/*.a[cm] {0}/*.py 2>/dev/null | wc -l".format(tmpdirname)).strip()
try:
with open("configure.ac") as f:
AC_INIT = list(filter(lambda x: re.match('AC_INIT', x),