aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--configure.in2
-rw-r--r--driver.c3
-rw-r--r--fetchmail.c3
3 files changed, 7 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 91dae06e..a3935000 100644
--- a/configure.in
+++ b/configure.in
@@ -23,7 +23,7 @@ AC_HEADER_STDC
AC_TYPE_SIZE_T
AC_TYPE_PID_T
AC_TYPE_SIGNAL
-AC_CHECK_HEADERS(unistd.h termios.h termio.h sgtty.h stdarg.h)
+AC_CHECK_HEADERS(unistd.h termios.h termio.h sgtty.h stdarg.h alloca.h)
AC_C_CONST dnl getopt needs this.
diff --git a/driver.c b/driver.c
index c28098b2..5f69bdcd 100644
--- a/driver.c
+++ b/driver.c
@@ -22,6 +22,9 @@
#else
#include <varargs.h>
#endif
+#if defined(HAVE_ALLOCA_H)
+#include <alloca.h>
+#endif
#include <sys/time.h>
#include <signal.h>
diff --git a/fetchmail.c b/fetchmail.c
index eb09f12d..a1990add 100644
--- a/fetchmail.c
+++ b/fetchmail.c
@@ -14,6 +14,9 @@
#if defined(HAVE_UNISTD_H)
#include <unistd.h>
#endif
+#if defined(HAVE_ALLOCA_H)
+#include <alloca.h>
+#endif
#include <string.h>
#include <signal.h>
#include <pwd.h>