aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--INSTALL2
-rw-r--r--Makefile.in12
-rw-r--r--configure.in10
3 files changed, 17 insertions, 7 deletions
diff --git a/INSTALL b/INSTALL
index 7676aff9..c82ffd4f 100644
--- a/INSTALL
+++ b/INSTALL
@@ -70,7 +70,7 @@ will do that.
To enable multilingual support using GNU gettext,
- configure --prefix=/usr --enable-NLS
+ configure --prefix=/usr --enable-nls
The prefix argument is needed to generate the makefiles in the po directory
correctly; otherwise, they'll install the internationalization stuff in
diff --git a/Makefile.in b/Makefile.in
index 0494a0cb..b97f1a2f 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -114,7 +114,7 @@ fetchmail: $(objs)
$(CC) $(LDEFLAGS) $(LDFLAGS) $(objs) $(LOADLIBS) -o fetchmail
po: dummy
- make -C po
+ @POMAKE@
dummy:
@@ -151,28 +151,28 @@ install:
$(INSTALL_DATA) $(srcdir)/fetchmail.man $(mandir)/fetchmail.$(manext)
ln -f -s $(mandir)/fetchmail.$(manext) $(mandir)/fetchmailconf.$(manext)
@echo "Installing language catalogs..."
- make -C po install
+ @POMAKE@ install
uninstall:
rm -f $(bindir)/fetchmail $(bindir)/fetchmailconf
rm -f $(mandir)/fetchmail.$(manext) $(mandir)/fetchmailconf.$(manext)
- make -C po uninstall
+ @POMAKE@ uninstall
.PHONY: clean realclean distclean mostlyclean
clean:
- make -C po clean
+ @POMAKE@ clean
-rm -f fetchmail *.o core fetchmail.dvi \
rcfile_l.c rcfile_y.h rcfile_y.c \
fetchmail.tar fetchmail.tar.gz \
rfc822 unmime
distclean: clean
- make -C po distclean
+ @POMAKE@ distclean
-rm -f Makefile config.h TAGS tags
-rm -f config.cache config.status config.log stamp-config
realclean: distclean
- make -C po clean
+ @POMAKE@ clean
-rm -f FAQ FEATURES NOTES MANIFEST
-rm -f config.cache config.log Makefile
-rm -f fetchmail-*.tar.gz fetchmail-*.i386.rpm
diff --git a/configure.in b/configure.in
index 52b2bd39..8d7427de 100644
--- a/configure.in
+++ b/configure.in
@@ -33,6 +33,7 @@ AC_SUBST(CPFLAGS)
AC_SUBST(CEFLAGS)
AC_SUBST(LDEFLAGS)
AC_SUBST(LIBOBJS)
+AC_SUBST(POMAKE)
# Check for LynxOS special case: -lbsd needed (at least on 2.3.0) and -s
# not working.
@@ -191,6 +192,15 @@ AC_CHECK_SIZEOF(short)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(long)
+if test "$USE_NLS" = "yes"
+then
+ echo "Enabling internationalization support..."
+ POMAKE="make -C po"
+else
+ echo "Disabling internationalization support..."
+ POMAKE="@echo '(NLS support disabled)'; #"
+fi
+
### use option --enable-POP2 to compile in the POP2 support
AC_ARG_ENABLE(POP2,
[ --enable-POP2 compile in POP2 protocol support (obsolete)],