aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS3
-rw-r--r--configure.in8
-rw-r--r--driver.c2
3 files changed, 12 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index f622e71a..53b9b796 100644
--- a/NEWS
+++ b/NEWS
@@ -6,6 +6,9 @@
Release Notes:
+pl 2.0.1 ():
+* Include Nalin Dahyabhai's patch for MIT Kerberos support.
+
fetchmail-2.0 (Mon Nov 18 00:32:17 EST 1996):
* Fix typo in setitimer call setup that caused obscure bugs under FreeBSD.
diff --git a/configure.in b/configure.in
index a7414204..91dae06e 100644
--- a/configure.in
+++ b/configure.in
@@ -57,6 +57,14 @@ then
LIBS="$LIBS -lkrb -ldes"
fi
+if test -f "/usr/athena/include/krb.h"
+then
+ CFLAGS="$CFLAGS -DKERBEROS_V4 -I/usr/athena/include"
+ LDFLAGS="$LDFLAGS -L/usr/athena/lib"
+ LIBS="$LIBS -lkrb -ldes"
+fi
+
+
dnl All AC_CHECK_FUNCs must precede the following AC_SUBSTs
AC_SUBST(EXTRASRC)
diff --git a/driver.c b/driver.c
index 95e4c45c..3272f523 100644
--- a/driver.c
+++ b/driver.c
@@ -613,7 +613,7 @@ struct query *ctl; /* query control record */
#ifdef KERBEROS_V4
int
-kerberos_auth (int socket, canonical)
+kerberos_auth (socket, canonical)
/* authenticate to the server host using Kerberos V4 */
int socket; /* socket to server host */
const char *canonical; /* server name */