aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS2
-rw-r--r--configure.ac5
2 files changed, 5 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index ec274250..69969d04 100644
--- a/NEWS
+++ b/NEWS
@@ -59,6 +59,8 @@ fetchmail 6.3.5 (not yet released):
* When using NTLM authentication, use regular IMAP response code handler after
completing NTLM handshake, for robustness and consistency.
(Taken from the NetBSD portable packages collection, patch-ac.)
+* Support Kerberos installations where krb5.h and perhaps roken.h are in
+ .../include/krb5. Taken from NetBSD portable packages collection patch-ae.
* On NetBSD, link against -lroken -lcom_err if --with-kerberos is enabled.
* Drop #include <com_err.h> from Kerberos 5 header file, fixes compile error on
SUSE Linux 10.0.
diff --git a/configure.ac b/configure.ac
index e453268f..7b47be0f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -448,10 +448,11 @@ else
with_kerberos5=
for dir in $searchdirs
do AC_MSG_CHECKING([for Kerberos V in $dir])
- if test -f "$dir/include/krb5.h"
+ if test -f "$dir/include/krb5.h" || test -f "$dir/include/krb5/krb5.h"
then
+ if test -d "$dir/include/krb5" ; then CPFLAGS="$CPFLAGS -I$dir/include/krb5" ; fi
ac_krblibs=
- if test -f "$dir/include/roken.h"
+ if test -f "$dir/include/roken.h" || test -f "$dir/include/krb5/roken.h"
then
ac_krblibs="-lasn1 -lroken -lcom_err"
AC_MSG_RESULT([Heimdal found])