diff options
-rw-r--r-- | NEWS | 2 | ||||
-rw-r--r-- | acconfig.h | 2 | ||||
-rw-r--r-- | configure.in | 3 | ||||
-rw-r--r-- | options.c | 2 |
4 files changed, 6 insertions, 3 deletions
@@ -2,6 +2,8 @@ (The `lines' figures total .c, .h, .l, and .y files under version control.) +* Fix configuration error in handling of long options. + fetchmail-5.9.2 (Wed Sep 26 12:47:00 EDT 2001), 21118 lines: * Enable code to build on Solaris again (long options won't work). @@ -19,7 +19,7 @@ #undef HAVE_CATGETS /* Define if you have GNU's getopt family of functions. */ -#undef HAVE_GETOPTLONG +#undef HAVE_GETOPT_LONG /* Define as 1 if you have gettext and don't want to use GNU gettext. */ #undef HAVE_GETTEXT diff --git a/configure.in b/configure.in index 710a93fc..de4ddffc 100644 --- a/configure.in +++ b/configure.in @@ -129,7 +129,8 @@ AC_SUBST(EXTRAOBJ) AC_CHECK_FUNCS(tcsetattr stty setsid geteuid seteuid gethostbyname \ res_search herror strrchr strerror setlinebuf syslog \ snprintf vprintf vsnprintf vsyslog \ - atexit inet_aton strftime setrlimit socketpair sigprocmask sigaction) + atexit inet_aton strftime setrlimit socketpair sigprocmask sigaction \ + getopt_long) # Under Red Hat 4.0 (and many other Linuxes) -lresolv is seriously flaky # and breaks gethostbyname(2). It's better to use the bind stuff in the C @@ -276,7 +276,7 @@ struct query *ctl; /* option record to be initialized */ ctl->smtp_socket = -1; while (!errflag && -#ifdef HAVE_GETOPTLONG +#ifdef HAVE_GETOPT_LONG (c = getopt_long(argc,argv,shortoptions, longoptions, &option_index)) != -1) #else |