aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in6
-rw-r--r--acconfig.h145
-rw-r--r--configure.in66
3 files changed, 34 insertions, 183 deletions
diff --git a/Makefile.in b/Makefile.in
index 3d38ed22..580d46f1 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -216,9 +216,9 @@ ${srcdir}/configure: configure.in aclocal.m4
# autoheader might not change config.h.in, so touch a stamp file.
${srcdir}/config.h.in: stamp-h.in
-${srcdir}/stamp-h.in: configure.in aclocal.m4 acconfig.h # config.h.top config.h.bot
- cd ${srcdir} # && @AUTOHEADER@
- echo timestamp> ${srcdir}/stamp-h.in
+${srcdir}/stamp-h.in: configure.in aclocal.m4
+ cd ${srcdir} && @AUTOHEADER@
+ echo timestamp > ${srcdir}/stamp-h.in
config.h: stamp-h
stamp-h: config.h.in config.status
diff --git a/acconfig.h b/acconfig.h
deleted file mode 100644
index 7fd0753e..00000000
--- a/acconfig.h
+++ /dev/null
@@ -1,145 +0,0 @@
-/* acconfig.h
- This file is in the public domain.
-
- Descriptive text for the C preprocessor macros that
- the distributed Autoconf macros can define.
- No software package will use all of them; autoheader copies the ones
- your configure.in uses into your configuration header file templates.
-
- Leave the following blank line there!! Autoheader needs it. */
-
-
-/* Define to 1 if NLS is requested. */
-#undef ENABLE_NLS
-
-/* Define if you have atexit */
-#undef HAVE_ATEXIT
-
-/* Define as 1 if you have catgets and don't want to use GNU gettext. */
-#undef HAVE_CATGETS
-
-/* Define as 1 if you have gettext and don't want to use GNU gettext. */
-#undef HAVE_GETTEXT
-
-/* Define if you have MIT kerberos */
-#undef HAVE_GSS_C_NT_HOSTBASED_SERVICE
-
-/* Define if you have herror available in your bind library */
-#undef HAVE_HERROR
-
-/* Define if your locale.h file contains LC_MESSAGES. */
-#undef HAVE_LC_MESSAGES
-
-/* Define if you have md5 in libc. */
-#undef HAVE_MD5
-
-/* Define if you have the memmove function. */
-#undef HAVE_MEMMOVE
-
-/* Define if you have on_exit */
-#undef HAVE_ON_EXIT
-
-/* Define if you have res_search available in your bind library */
-#undef HAVE_RES_SEARCH
-
-/* Define if you have setrlimit */
-#undef HAVE_SETRLIMIT
-
-/* Define if you want built-in SOCKS support */
-#undef HAVE_SOCKS
-
-/* Define as 1 if you have the stpcpy function. */
-#undef HAVE_STPCPY
-
-/* Define if you have the strcasecmp function. */
-#undef HAVE_STRCASECMP
-
-/* Define if you have strstr */
-#undef HAVE_STRSTR
-
-/* Define if `union wait' is the type of the first arg to wait functions. */
-#undef HAVE_UNION_WAIT
-
-/* Define if your C compiler allows void * as a function result */
-#undef HAVE_VOIDPOINTER
-
-/* Define if your C compiler allows ANSI volatile */
-#undef HAVE_VOLATILE
-
-/* Define if you have vsyslog */
-#undef HAVE_VSYSLOG
-
-/* Define to the name of the distribution. */
-#undef PACKAGE
-
-/* Compute an appropriate directory for PID lock files */
-#undef PID_DIR
-
-/* Define to help us deduce a 32-bit type (required for Kerberos) */
-#undef SIZEOF_INT
-#undef SIZEOF_SHORT
-#undef SIZEOF_LONG
-
-/* Define if you want POP3 support compiled in */
-#undef POP3_ENABLE
-
-/* Define if you want POP2 support compiled in */
-#undef POP2_ENABLE
-
-/* Define if you want IMAP support compiled in */
-#undef IMAP_ENABLE
-
-/* Define if you want ETRN support compiled in */
-#undef ETRN_ENABLE
-
-/* Define if you want ODMR support compiled in */
-#undef ODMR_ENABLE
-
-/* Define if you want RPA support compiled in */
-#undef RPA_ENABLE
-
-/* Define if you want NTLM authentication */
-#undef NTLM_ENABLE
-
-/* Define if you want SDPS support compiled in */
-#undef SDPS_ENABLE
-
-/* Define if you want SSL support compiled in */
-#undef SSL_ENABLE
-
-/* Define if you want OPIE support compiled in */
-#undef OPIE_ENABLE
-
-/* Define if you want IPv6 support compiled in */
-#undef INET6_ENABLE
-
-/* Define if you want network security support compiled in */
-#undef NET_SECURITY
-
-/* Define if you want GSSAPI authentication */
-#undef GSSAPI
-
-/* Define if you have Kerberos V4 */
-#undef KERBEROS_V4
-
-/* Define if you have Kerberos V5 */
-#undef KERBEROS_V5
-
-/* Define if you have HEIMDAL kerberos 5 */
-#undef HEIMDAL
-
-/* Define to the version of the distribution. */
-#undef VERSION
-
-/* Define if you have a fallback MDA installed */
-#undef FALLBACK_MDA
-
-/* Define if `sys_siglist' is declared by <signal.h>. */
-#undef SYS_SIGLIST_DECLARED
-
-
-/* Leave that blank line there!! Autoheader needs it.
- If you're adding to this file, keep in mind:
- The entries are in sort -df order: alphabetical, case insensitive,
- ignoring punctuation (such as underscores). */
-
diff --git a/configure.in b/configure.in
index a24f96a3..97c05ebd 100644
--- a/configure.in
+++ b/configure.in
@@ -97,19 +97,19 @@ dnl Port hack for Sparc/NetBSD-1.5
AC_CHECK_LIB(intl, gettext,
[LIBS="$LIBS -lintl"])
-AC_CHECK_FUNC(strstr, AC_DEFINE(HAVE_STRSTR),
+AC_CHECK_FUNC(strstr, AC_DEFINE(HAVE_STRSTR,1,Define to 1 if you have the 'strstr' function),
[EXTRASRC="$EXTRASRC \$(srcdir)/strstr.c"
EXTRAOBJ="$EXTRAOBJ strstr.o"])
-AC_CHECK_FUNC(strcasecmp, AC_DEFINE(HAVE_STRCASECMP),
+AC_CHECK_FUNC(strcasecmp, AC_DEFINE(HAVE_STRCASECMP,1,Define to 1 if you have the 'strcasecmp' function),
[EXTRASRC="$EXTRASRC \$(srcdir)/strcasecmp.c"
EXTRAOBJ="$EXTRAOBJ strcasecmp.o"])
-
-AC_CHECK_FUNC(memmove, AC_DEFINE(HAVE_MEMMOVE),
+
+AC_CHECK_FUNC(memmove, AC_DEFINE(HAVE_MEMMOVE,1,Define to 1 if you have the 'memmove' function),
[EXTRASRC="$EXTRASRC \$(srcdir)/memmove.c"
EXTRAOBJ="$EXTRAOBJ memmove.o"])
-
-AC_CHECK_FUNC(MD5Init, AC_DEFINE(HAVE_MD5),
+
+AC_CHECK_FUNC(MD5Init, AC_DEFINE(HAVE_MD5,1,Define if you have m5 in libc),
[EXTRASRC="$EXTRASRC \$(srcdir)/md5c.c"
EXTRAOBJ="$EXTRAOBJ md5c.o"])
@@ -119,7 +119,7 @@ AC_CHECK_FUNC(getopt_long, AC_DEFINE(HAVE_GETOPT_LONG),
AC_FUNC_VPRINTF
AC_FUNC_ALLOCA
-if test -n "$ALLOCA"
+if test -n "$ALLOCA"
then
EXTRASRC="$EXTRASRC \$(srcdir)/alloca.c"
EXTRAOBJ="$EXTRAOBJ alloca.o"
@@ -162,15 +162,11 @@ AC_TRY_COMPILE([],
void *xmalloc();
p = (char *) xmalloc(1);
],
- [AC_DEFINE(HAVE_VOIDPOINTER) AC_MSG_RESULT(yes)],
+ [AC_DEFINE(HAVE_VOIDPOINTER,1,[Define if your C compiler allows void * as a function result]) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
dnl Check for ANSI volatile
-AC_MSG_CHECKING(for ANSI volatile)
-AC_TRY_COMPILE([],
- [volatile int n;],
- [AC_DEFINE(HAVE_VOLATILE) AC_MSG_RESULT(yes)],
- AC_MSG_RESULT(no))
+AC_C_VOLATILE
dnl Check out the wait reality. We have to assume sys/wait.h is present.
AC_CHECK_FUNCS(waitpid wait3)
@@ -189,7 +185,7 @@ if (WEXITSTATUS (status) != 0) pid = -1;
pid = waitpid (-1, &status, 0);
#endif
],
- [AC_DEFINE(HAVE_UNION_WAIT) AC_MSG_RESULT(yes)],
+[AC_DEFINE(HAVE_UNION_WAIT,1,Define if 'union wait' is the type of the first arg to wait functions.) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
AC_MSG_CHECKING(sys_siglist declaration in signal.h or unistd.h)
@@ -198,7 +194,7 @@ AC_TRY_LINK([#include <signal.h>
#ifdef HAVE_UNISTD_H
#include <unistd.h>
#endif], [char *msg = *(sys_siglist + 1);],
- [AC_DEFINE(SYS_SIGLIST_DECLARED) AC_MSG_RESULT(yes)],
+ [AC_DEFINE(SYS_SIGLIST_DECLARED,1,[Define if 'sys_siglist' is declared by <signal.h>.]) AC_MSG_RESULT(yes)],
AC_MSG_RESULT(no))
# Find the right directory to put the root-mode PID file in
@@ -210,7 +206,7 @@ do
fi
done
AC_MSG_RESULT(root-mode pid file will go in $dir)
-AC_DEFINE_UNQUOTED(PID_DIR, "$dir")
+AC_DEFINE_UNQUOTED(PID_DIR, "$dir", directory for PID lock files)
# We may have a fallback MDA available in case the socket open to the
# local SMTP listener fails. Best to use procmail for this, as we know
@@ -269,7 +265,7 @@ case "$enable_fallback" in
AC_ERROR([Sendmail selected as fallback, but not found])
#not reached
fi
- AC_DEFINE_UNQUOTED(FALLBACK_MDA, "$sendmail -i %T")
+ AC_DEFINE_UNQUOTED(FALLBACK_MDA, "$sendmail -i %T", Fallback MTA to use if defined)
echo "Will use $sendmail as fallback MDA."
;;
procmail) if test -z "$procmail" ; then
@@ -310,56 +306,56 @@ AC_ARG_ENABLE(POP2,
[ --enable-POP2 compile in POP2 protocol support (obsolete)],
[with_POP2=$enableval],
[with_POP2=no])
-test "$with_POP2" = "yes" && AC_DEFINE(POP2_ENABLE)
+test "$with_POP2" = "yes" && AC_DEFINE(POP2_ENABLE,1,Define if you want POP2 support compiled in)
### use option --disable-POP3 to omit the POP3 support
AC_ARG_ENABLE(POP3,
[ --disable-POP3 don't compile in POP3 protocol support],
[with_POP3=$enableval],
[with_POP3=yes])
-test "$with_POP3" = "yes" && AC_DEFINE(POP3_ENABLE)
+test "$with_POP3" = "yes" && AC_DEFINE(POP3_ENABLE,1,Define if you want POP3 support compiled in)
### use option --disable-IMAP to omit the IMAP support
AC_ARG_ENABLE(IMAP,
[ --disable-IMAP don't compile in IMAP protocol support],
[with_IMAP=$enableval],
[with_IMAP=yes])
-test "$with_IMAP" = "yes" && AC_DEFINE(IMAP_ENABLE)
+test "$with_IMAP" = "yes" && AC_DEFINE(IMAP_ENABLE,1,"Define if you want IMAP support compiled in")
### use option --disable-ETRN to omit the ETRN support
AC_ARG_ENABLE(ETRN,
[ --disable-ETRN don't compile in ETRN protocol support],
[with_ETRN=$enableval],
[with_ETRN=yes])
-test "$with_ETRN" = "yes" && AC_DEFINE(ETRN_ENABLE)
+test "$with_ETRN" = "yes" && AC_DEFINE(ETRN_ENABLE,1,Define if you want ETRN support compiled in.)
### use option --disable-ODMR to omit the ODMR support
AC_ARG_ENABLE(ODMR,
[ --disable-ODMR don't compile in ODMR protocol support],
[with_ODMR=$enableval],
[with_ODMR=yes])
-test "$with_ODMR" = "yes" && AC_DEFINE(ODMR_ENABLE)
+test "$with_ODMR" = "yes" && AC_DEFINE(ODMR_ENABLE,1,Define if you want ODMR support compiled in)
### use option --enable-RPA to compile in the RPA support
AC_ARG_ENABLE(RPA,
[ --enable-RPA compile in RPA protocol support],
[with_RPA=$enableval],
[with_RPA=no])
-test "$with_RPA" = "yes" && AC_DEFINE(RPA_ENABLE)
+test "$with_RPA" = "yes" && AC_DEFINE(RPA_ENABLE,1,Define if you want RPA support compiled in)
### use option --enable-NTLM to compile in the NTLM support
AC_ARG_ENABLE(NTLM,
[ --enable-NTLM compile in NTLM authentication support],
[with_NTLM=$enableval],
[with_NTLM=no])
-test "$with_NTLM" = "yes" && AC_DEFINE(NTLM_ENABLE)
+test "$with_NTLM" = "yes" && AC_DEFINE(NTLM_ENABLE,1,Define if you want NTLM authentication)
### use option --enable-SDPS to compile in the SDPS support
AC_ARG_ENABLE(SDPS,
[ --enable-SDPS compile in SDPS protocol support],
[with_SDPS=$enableval],
[with_SDPS=no])
-test "$with_SDPS" = "yes" && AC_DEFINE(SDPS_ENABLE)
+test "$with_SDPS" = "yes" && AC_DEFINE(SDPS_ENABLE,1,Define if you want SDPS support compiled in)
### use option --enable-opie to compile in the OPIE support
AC_ARG_ENABLE(opie,
@@ -368,7 +364,7 @@ AC_ARG_ENABLE(opie,
AC_CHECK_LIB(opie,opiegenerator,, [echo 'configure: cannot find libopie, which is required for OPIE support.'; exit 1])
with_opie=$enableval],
[with_opie=no])
-test "$with_opie" = "yes" && AC_DEFINE(OPIE_ENABLE)
+test "$with_opie" = "yes" && AC_DEFINE(OPIE_ENABLE,1,Define if you want OPIE support compiled in)
AC_ARG_ENABLE(inet6,
[ --enable-inet6 support IPv6 (requires the inet6-apps library)],
@@ -381,7 +377,7 @@ AC_ARG_ENABLE(inet6,
echo ' which is required for IPv6 support.';
exit 1]) ] )],
[with_inet6=no])
-test "$with_inet6" = "yes" && AC_DEFINE(INET6_ENABLE)
+test "$with_inet6" = "yes" && AC_DEFINE(INET6_ENABLE,1,Define if you want IPv6 support compiled in)
AC_CHECK_FUNCS(inner_connect)
@@ -403,7 +399,7 @@ AC_ARG_ENABLE(netsec,
echo ' for network security support.';
exit 1]) ]) ]
[with_netsec=no])
-test "$with_netsec" = "yes" && AC_DEFINE(NET_SECURITY)
+test "$with_netsec" = "yes" && AC_DEFINE(NET_SECURITY,1,Define if you want network security support compiled in)
# This version of the Kerberos 4 and 5 options addresses the follwing issues:
#
@@ -432,8 +428,8 @@ then
if test "$with_kerberos5" = "yes" && ( test `uname` = "OpenBSD" )
then
AC_CHECKING([kerberosV for OpenBSD])
- AC_DEFINE(HEIMDAL)
- AC_DEFINE(KERBEROS_V5)
+ AC_DEFINE(HEIMDAL,1,Define if you have HEIMDAL kerberos 5)
+ AC_DEFINE(KERBEROS_V5,1,Define if you have Kerberos V5)
CEFLAGS="$CEFLAGS -I/usr/include/kerberosV"
LIBS="$LIBS -lasn1 -lkrb5 -lcom_err -lkafs"
else
@@ -508,7 +504,7 @@ then
if test "$with_kerberos" = "yes" && ( test `uname` = "NetBSD" || test `uname` = "OpenBSD" )
then
AC_CHECKING([kerberosIV for `uname`])
- AC_DEFINE(KERBEROS_V4)
+ AC_DEFINE(KERBEROS_V4,1,Define if you have Kerberos V4)
CEFLAGS="$CEFLAGS -I/usr/include/kerberosIV"
LIBS="$LIBS -lkrb -ldes"
else
@@ -564,7 +560,7 @@ AC_ARG_WITH(ssl,
[ --with-ssl=[DIR] enable SSL support using libraries in DIR],
[with_ssl=$withval],
[with_ssl=no])
-test "$with_ssl" != "no" && AC_DEFINE(SSL_ENABLE)
+test "$with_ssl" != "no" && AC_DEFINE(SSL_ENABLE,1,Define if you want SSL support compiled in)
if test "$with_ssl" = "yes"
then
@@ -634,7 +630,7 @@ then
AC_CHECK_LIB(socks, Rconnect,,
AC_MSG_ERROR([could not find libsocks which is needed for built-in SOCKS support]))
fi
- AC_DEFINE(HAVE_SOCKS)
+ AC_DEFINE(HAVE_SOCKS,1,Define if you want built-in SOCKS support)
CEFLAGS="$CEFLAGS -Dconnect=Rconnect -Dgetsockname=Rgetsockname -Dbind=Rbind -Daccept=Raccept -Dlisten=Rlisten -Dselect=Rselect"
LIBS="-lsocks $LIBS"
fi])
@@ -719,12 +715,12 @@ then
AC_MSG_ERROR([could not find libgssapi_krb5 which is needed for GSSAPI support]), -lkrb5)
fi
fi
- AC_DEFINE(GSSAPI)
+ AC_DEFINE(GSSAPI,1,Define if you want GSSAPI authentication)
save_CPPFLAGS=$CPPFLAGS
CPPFLAGS="-I$with_gssapi/include"
AC_CHECK_HEADERS(gss.h gssapi.h gssapi/gssapi.h gssapi/gssapi_generic.h)
if test "$ac_cv_header_gssapi_h" = "yes"; then
- AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE))
+ AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE,1,Define if you have MIT kerberos))
else
AC_EGREP_HEADER(GSS_C_NT_HOSTBASED_SERVICE, gssapi/gssapi.h, AC_DEFINE(HAVE_GSS_C_NT_HOSTBASED_SERVICE))
fi