aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS8
-rw-r--r--configure.in2
-rw-r--r--imap.c6
3 files changed, 13 insertions, 3 deletions
diff --git a/NEWS b/NEWS
index 25f6014b..ed0dc7ac 100644
--- a/NEWS
+++ b/NEWS
@@ -9,6 +9,14 @@
Release Notes:
fetchmail-5.0.8 (Tue Sep 14 06:56:50 EDT 1999):
+* CRAM-MD5 code now doublequotes usernames with embedded spaces. This will
+ probably fail (the RFCs don't support quoting) but it's better than nothing
+ and works with at least one server.
+* Federico G. Schwindt's fix for NetBSD/OpenBSD --with-kerberos.
+
+There are 264 people on fetchmail-friends and 441 on fetchmail-announce.
+
+fetchmail-5.0.8 (Tue Sep 14 06:56:50 EDT 1999):
* Todd Sabin's patch to accept spaces in CRAM-MD5 names.
* Fix to CRAM endianness patch, by Dan Root via Lawrence Rogers.
* Suppress duplicates by message ID in multidrop mode.
diff --git a/configure.in b/configure.in
index ace29821..f146305e 100644
--- a/configure.in
+++ b/configure.in
@@ -354,7 +354,7 @@ AC_ARG_WITH(kerberos,
# configuring the BSD/OS Kerberos IV support, though.
# Check for a NetBSD/OpenBSD special case
-if test "$with_kerberos" = "yes" -a `uname` = "NetBSD" -o `uname` = "OpenBSD"
+if test "$with_kerberos" = "yes" && test `uname` = "NetBSD" -o `uname` = "OpenBSD"
then
echo "Configuring kerberosIV for `uname`"
CEFLAGS="$CEFLAGS -DKERBEROS_V4 -I/usr/include/kerberosIV"
diff --git a/imap.c b/imap.c
index 12f288f0..5d62a135 100644
--- a/imap.c
+++ b/imap.c
@@ -749,6 +749,7 @@ static int do_cram_md5 (int sock, struct query *ctl)
{
int result;
int len;
+ int quot;
unsigned char buf1[1024];
unsigned char msg_id[768];
unsigned char response[16];
@@ -792,13 +793,14 @@ static int do_cram_md5 (int sock, struct query *ctl)
msg_id, strlen (msg_id),
response, sizeof (response));
+ quot = (int) strpbrk (ctl->remotename, " ");
#ifdef HAVE_SNPRINTF
snprintf (reply, sizeof (reply),
#else
sprintf(reply,
#endif
- "\"%s\" %02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x",
- ctl->remotename,
+ "%s%s%s %02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x%02x",
+ quot ? "\"" : "", ctl->remotename, quot ? "\"" : "",
response[0], response[1], response[2], response[3],
response[4], response[5], response[6], response[7],
response[8], response[9], response[10], response[11],