aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.in2
-rw-r--r--NEWS4
-rw-r--r--pop3.c4
3 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index c3f6b409..e801cc1e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -124,7 +124,7 @@ tags: $(tagsrcs)
.PHONY: install installdirs
install: installdirs \
- $(bindir)/$(instname) $(infodir)/popclient.info \
+ $(bindir)/$(instname) # $(infodir)/popclient.info \
$(mandir)/$(instname).$(manext)
installdirs:
diff --git a/NEWS b/NEWS
index 77d57493..51f67ef4 100644
--- a/NEWS
+++ b/NEWS
@@ -19,6 +19,10 @@ S/key for secure challenge-response.
Implement IMAP support.
+3.03:
+
+* Minor bug fixes for password querying and redirection to stdout.
+
3.02:
* Correct buggy processing of nokeep/noflush/fetchall.
diff --git a/pop3.c b/pop3.c
index 0be6b211..5571d6d9 100644
--- a/pop3.c
+++ b/pop3.c
@@ -70,8 +70,8 @@ struct hostrec *queryctl;
int first,number,count;
- /* open/lock the folder if we're using a mailbox */
- if (queryctl->output == TO_FOLDER)
+ /* open stdout or the mailbox, locking it if it is a folder */
+ if (queryctl->output == TO_FOLDER || queryctl->output == TO_STDOUT)
if ((mboxfd = openuserfolder(queryctl)) < 0)
return(PS_IOERR);