aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--NEWS1
-rw-r--r--configure.ac5
2 files changed, 5 insertions, 1 deletions
diff --git a/NEWS b/NEWS
index de89ef6f..1ce8459b 100644
--- a/NEWS
+++ b/NEWS
@@ -59,6 +59,7 @@ fetchmail 6.3.5 (not yet released):
* When using NTLM authentication, use regular IMAP response code handler after
completing NTLM handshake, for robustness and consistency.
(Taken from the NetBSD portable packages collection, patch-ac.)
+* On NetBSD, link against -lroken -lcom_err if --with-kerberos is enabled.
# CHANGES:
* Rename all fetchmail-internal lock_* functions to fm_lock_*. Obsoletes
diff --git a/configure.ac b/configure.ac
index 06d5357a..f2aa1cb6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -510,7 +510,10 @@ then
AS_MESSAGE(checking kerberosIV for `uname`...)
AC_DEFINE(KERBEROS_V4,1,Define if you have Kerberos V4)
CEFLAGS="$CEFLAGS -I/usr/include/kerberosIV"
- LIBS="$LIBS -lkrb -ldes"
+ case `uname` in
+ NetBSD) LIBS="$LIBS -lkrb -ldes -lroken -lcom_err" ;;
+ OpenBSD) LIBS="$LIBS -lkrb -ldes" ;;
+ esac
elif krb4-config 2> /dev/null >/dev/null ; then
krb4_prefix=`krb4-config --prefix`
AC_MSG_RESULT([krb4-config points to kerberosIV under $krb4_prefix])